On Mon, Dec 14, 2009 at 10:53 PM, Jarod Wilson <jarod@wilsonet.com> wrote:
On Dec 4, 2009, at 11:40 AM, Travis Tabbal wrote:

> This is the ID of the reciever:
> Bus 004 Device 002: ID 1784:0008 TopSeed Technology Corp.
> After getting it running, I get lots of lockups at seemingly random times, right after using the remote. I can't seem to get any logging on the issue, though I have seen posts on an XBMC forum suspecting a chipset/receiver interop issue. After this happens, the machine is hard locked. I don't get any response from a local keyboard, and can't SSH into the machine. It's like the kernel crashes. I was wondering if anyone here has some hints on getting this fixed? I don't know if it's LIRC itself, the mceusb driver, or just faulty hardware. The machine works fine if I just use a keyboard, but that's not really TV friendly. On the XBMC forums, they suggested adding a USB card as a solution. I'm thinking of trying that tonight as I have an old PCI USB card, if I can find it. I have tried different ports on the motherboard USB already.
> Distro is Ubuntu 9.10. LIRC installed from packages, version 0.8.6. Motherboard is an Asus M3N78-VM.

Having used several mceusb devices over time with several different machines, I'd be inclined to say there's some sort of issue specific to your hardware. More likely a usb chipset issue than anything else. Trying out a pci usb card is definitely a good step to try out.

Thanks for the reply. I tried a new card with similar results. I completely rebuilt the software install and so far it seems to be working fine. I must have had some kind of software problem. I'm not sure what I could have had messed up, but it's run far longer now that it had before without any issues. I'm using the same hardware.conf and lircd.conf, but I guess I could have had something messed up in a kernel module or something.