I have a more "delicate" problem - I have a Leadtek TV2000XP Expert TV tuner. I compiled lirc with driver "devinput", as the tuner is recognised by the kernel:

I: Bus=0001 Vendor=107d Product=6611 Version=0001
N: Name="cx88 IR (Leadtek Winfast 2000XP"
P: Phys=pci-0000:00:0b.0/ir0
S: Sysfs=/class/input/input3
H: Handlers=kbd event3
B: EV=100003
B: KEY=10afc336 2150a48 0 0 0 404 80010000 190 4801 1e0000 4400 100000 10000ffc

The problem is, I have to press a button 20 to 30 times until it actually does what's supposed to do, once (so it's not like it's not working at all, it's just working once in 20 - 30 tries).  I have even tried running lircd in debug mode, but there is no relevant info - it's just as if the remote is not working properly. But I have a dual boot system, and in Windows the remote is working perfectly! So that must mean it's more of a driver problem? Any suggestions as to how i could fix this?

I have also tried using the leadtek_0010 driver - but when I try to insert the lirc_gpio module it says:

FATAL: Error inserting lirc_gpio (/lib/modules/2.6.18/misc/lirc_gpio.ko): Invalid request code

and in dmesg:

The bttv_* interface is obsolete and will go away,
please use the new, sysfs based interface instead.
lirc_gpio (-1): could not get card type

I have searched the internet for long hours in the last couple of days, but I couldn't find any information as to how I could help lirc_gpio "get the card type", or how to fix the devinput problem.

Could anyone help me with some pointers here?

Thank you very much,