On 12/14/2012 12:34 PM, Christopher Moore wrote:
Hello everyone,

I just upgraded from mythbuntu 10.04 -> 12.04 and now my remote has stopped working, except for the 1 aspect/zoom button ( 000000037ff07bd8 ).  I've been searching through the web for solutions and so far nothing has worked.

What is working is my iguanair daemon ( 1.0.3-1ubuntu1 ) started successfully and registered the /dev/'s properly.  I can also communicate with it :

igclient --receiver-on --sleep 30
received 6 signal(s):
  pulse: 298
  space: 469
  pulse: 341
  space: 554
  pulse: 768
  space: 43690
received 1 signal(s):
  space: 152917

ll /dev/iguanaIR/
total 0
srwxrwxrwx 1 iguanair iguanair 0 Dec 14 10:15 0
srwxrwxrwx 1 iguanair iguanair 0 Dec 14 10:15 ctl
lrwxrwxrwx 1 iguanair iguanair 1 Dec 14 10:15 fred -_ 0

I also followed the directions on their page, as I did previously, to compile iguanair into lirc ( 0.9.0-0ubuntu1 ) and install the .deb's generated from the process.

ll /var/run/lirc/
total 8
srw-rw-rw- 1 root root 0 Dec 14 10:25 lircd
srw-rw-rw- 1 root root 0 Dec 14 10:25 lircd11
-rw-r--r-- 1 root root 5 Dec 14 10:25 lircd1.pid
-rw-r--r-- 1 root root 5 Dec 14 10:25 lircd.pid

REMOTE ARGS = --output=/var/run/lirc/lircd --driver=iguanaIR
--device=/dev/iguanaIR/0 --listen
TRANSMITTER ARGS = --output=/var/run/lirc/lircd11 --driver=iguanaIR
--device=/dev/iguanaIR/0 -H iguanaIR --connect=localhost:8765

irsend is also running and I can successfully send commands manually
using a terminal to my tv.

my hardware.conf remains unchanged from before :

#Chosen Remote Control
REMOTE="Iguanaworks USB IR Transceiver"

#Chosen IR Transmitter

irw, however only seems to register 1 command ( zoom ) and no other

I confirmed vs the /usr/share/lirc/remotes that no codes changed, and
my settings match.

I've attached my configuration files.

Any ideas ? I have thrown every config at this I have found for this remote.  The ir-keymap solution also does not work, probably b/c I am not using a mceusb receiver.   This makes no sense ...



LogMeIn Rescue: Anywhere, Anytime Remote support for IT. Free Trial
Remotely access PCs and mobile devices and provide instant support
Improve your efficiency, and focus on delivering more value-add services
Discover what IT Professionals Know. Rescue delivers

I should also mention that  I have tried running 'irrecord' and 'irrecord -f' to force raw mode, and still only that 1 button gets recognised.