OK, I surrender.  Is there a way to use the lirc_wb677 driver under kernel>2.6.38?

I have had no luck with the nuvoton-cir route.

Seems like there is no way to get it from pure input layer to lirc, and pure input send garbage keyboard signals.

Is there anyone that has the remote for the ASrock 330 working with any method under a recent kernel?

On 06/28/2011 07:09 PM, Brett Ginsburg wrote:
I have tried several things with no luck.

I tried editing the /etc/sysconfig/lircd file to:

# Customized settings for lirc daemon

# The hardware driver to use, run lircd --driver=? for a list
# Hardware driver module to load

I have also changed the driver to default, and changed the HWMOD to 
provide the name the system name shown by
 >for i in /sys/class/input/input* ; do echo -n "$(basename "$i"): "; 
cat "$i/name"; done

with the proper escape characters and also with a wildcard.

There was no change in the functionality of the remote.

I also added a rule to prevent HAL from controlling the IR receiver as 
described at:


I confirmed that the Nuvoton device section started with

"info.ignore = true  (bool)"

but neither restarting both daemons or rebooting changed the remote 
 From the page linked above:  "irw" in a xterm-window will appear to 
produce garbage characters which in fact are key-codes presented to the 
x-server through HAL. Some of the keys produce working x-events for 
left/right/up/down/enter and numbers, while others don't seem to work at 

This describes my problem even after the modifications described at the 
link and in the text above.

All of the data generated in your IT infrastructure is seriously valuable.
Why? It contains a definitive record of application performance, security 
threats, fraudulent activity, and more. Splunk takes this data and makes 
sense of it. IT sense. And common sense.