On 13/02/2011 10:08, Nick Morrott wrote:
On 13 February 2011 08:52, Nigel Jewell <nige@grufty.co.uk> wrote:
I have a machine that has three Hauppauge Nova-T's in it.  With CentOS 5
(x86_64) I was able to pick the right event file from /dev/input and
then use a lirc built with the devinput driver to receive ir codes.
Worked fine.
Were you using any udev rules to control/create the /dev/input devices
being created when these cards were modprobed?

No ... but in /etc/rc.d/rc.local I have a couple of lines that do something similar.  I'm 99% sure that I've got the right device as when I "cat" the device and press buttons on the remote I see characters.

Now I'm getting to point where I am stumped.  How can I try and work out
what is going on here and why irw is not outputting anything?
Which startup options is lircd starting up with (look at
/etc/sysconfig/lirc on Fedora)? Older LIRC installs needed to know
which /dev/input/eventX device to connect to (LIRC_DEVICE), in
addition to the LIRC driver to use (LIRC_DRIVER). If either of these
are not configured correctly, update these values and restart lircd
(note that irw needs lircd running correctly in order to produce
output).

I've tried running the daemon manually with:

lircd -H devinput -d /dev/input/event5 -n /etc/lirc/lircd.conf

and with the following /etc/sysconfig/lirc.conf

# Options to lircd(8).  Typically, this will be empty, as which driver to use
# should be specified using the LIRC_DRIVER variable below.
LIRCD_OPTIONS=""

# The infrared receiver (and/or transmitter) driver to be used by lircd(8),
# similar to passing "-H driver" to lircd(8).
# Run "/usr/sbin/lircd -H help" to get a listing of supported drivers.
LIRC_DRIVER="devinput"

# Which lirc device will be used by lircd(8).
# This is the same as passing "-d device" to lircd.
# An empty value will use the default /dev/lirc0 device.
LIRC_DEVICE="/dev/input/event5"

# If "yes", the init script will try to start lircmd(8) too.
ENABLE_LIRCMD="no"

# Options to lircmd(8).
LIRCMD_OPTIONS=""

Regards,
Nige.