Sorry about the repost, but I think the last one got lost in the nether because I didn't get any list messages for weeks after sending it, so here goes:

I asked a few questions about this device before, but I'm not sure if there's been any changes.

I originally thought it was dvico related because of the hiddev part, but think now that it's a variation of either the mceusb, or mceusb2 driver.  Unfortunately when I load the module for it, it doesn't work, it loads but doesn't find the device.  I tried modifying the lirc_mceusb2.c file to add the vendor and device numbers (0x041e and 0x3100 respectively) but it still doesn't pick it up.  The device itself is sitting at /dev/usb/hiddev0.  If I cat the device and hit buttons on the remote, I get a response but I can't get any of the tools that come with lirc to acknowlege that the device is anything it can recognize.

Here is the information that I have on it

[4294680.068000] hiddev96: USB HID v1.00 Device [Philips Electronics - RCS Singapore Creative USB IR Receiver] on usb-0000:00:10.0-1

lsusb -vv:
Bus 003 Device 002: ID 041e:3100 Creative Technology, Ltd
Device Descriptor:
  bLength                18
  bDescriptorType         1
  bcdUSB               1.10
  bDeviceClass            0 (Defined at Interface level)
  bDeviceSubClass         0
  bDeviceProtocol         0
  bMaxPacketSize0         8
  idVendor           0x041e Creative Technology, Ltd
  idProduct          0x3100
  bcdDevice            1.01
  iManufacturer           1 Philips Electronics - RCS Singapore
  iProduct                2 Creative USB IR Receiver
  iSerial                 0
  bNumConfigurations      1
  Configuration Descriptor:
    bLength                 9
    bDescriptorType         2
    wTotalLength           34
    bNumInterfaces          1
    bConfigurationValue     1
    iConfiguration          0
    bmAttributes         0xa0
      Remote Wakeup
    MaxPower              100mA
    Interface Descriptor:
      bLength                 9
      bDescriptorType         4
      bInterfaceNumber        0
      bAlternateSetting       0
      bNumEndpoints           1
      bInterfaceClass         3 Human Interface Devices
      bInterfaceSubClass      1 Boot Interface Subclass
      bInterfaceProtocol      0 None
      iInterface              0
        HID Device Descriptor:
          bLength                 9
          bDescriptorType        33
          bcdHID               1.00
          bCountryCode            0 Not supported
          bNumDescriptors         1
          bDescriptorType        34 Report
          wDescriptorLength      28
         Report Descriptors:
           ** UNAVAILABLE **
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x81  EP 1 IN
        bmAttributes            3
          Transfer Type            Interrupt
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0008  1x 8 bytes
        bInterval              10

Picture of the dongle:
The dongle I got, however, is completely black except with the work "CREATIVE" printed on the top of it.  (the remote in the picture is not what I got)

Picture of the remote:

On the bottom of the receiver is printed:
3139 228 65171

       Tested To Comply
       With FCC Standards


The output of the remote is posted here when I cat the device:

Any ideas?  Any new developments?