Is " I/O port 0x03e8, IRQ 4" the address of the ir port on your motherboard?

You should be able to find this info out from the bios or the motherboard manual.  This address usually corresponds to com3.  However, with a lot of pre-built kernels, com 1 to 4 are pre-built as literal com ports, which means while the ir port is plugged in, it isn't actually getting the com 3 address.

Further scrutiny of dmesg should show this.

You can re-compile the kernel to have less ports defined, or alternatively use the setserial command to disable the kernel port for com3:

    setserial /dev/ttyS2 uart none

Then rmmod and modprobe lirc_sir again.

If the address that lirc_sir is using is incorrect, then you can modprobe lirc_sir with the correct address.

Ryan Robinett wrote:

I tried that, but don’t see anything in the terminal window when I press keys on the remote. Is lirc_sir the wrong driver to load?


From: Paul Murphy []
Sent: Friday, August 24, 2007 9:27 PM
To: Ryan Robinett
Subject: Re: [forums] Actisys IR210L ...


I would try

    cat /dev/lirc0

and then press some buttons.  You should get junk appear on the screen with each press to indicate something is being received.

Ryan Robinett wrote:

I’m trying to get the Actisys IR210L ( working with Ubuntu Fiesty Fawn and was wondering if anyone has had any success. The IR210L plugs directly into the motherboard and I’ve verified that it works properly by booting into Windows and using windows IR to transfer a file.


Here’s what I’ve tried so far:


modprobe lirc_sir

dmesg shows:


lirc_dev: IR Remote Control driver registered, at major 61
lirc_dev: lirc_register_plugin: sample_rate: 0
lirc_sir: I/O port 0x03e8, IRQ 4.
lirc_sir: Installed.


After doing this, I now have a /dev/lirc0. I then tried running


irrecord –device=/dev/lirc0 foo.conf


But I’m unable to get it to recognize any button presses on my remotes (tried multiple). It keeps aborting after 10 seconds of no data.


Any ideas on what else I can try? Thanks in advance for any help.




This email is sponsored by: Splunk Inc.
Still grepping through log files to find problems?  Stop.
Now Search log events and configuration files using AJAX and a browser.
Download your FREE copy of Splunk now >>