From: Douglas Clowes
Sent: Friday, May 06, 2011 11:36 AM
To: Krister Hallergard
Cc: Jarod Wilson ;
Subject: Re: Lirc daemon running but no output in Kubuntu 11.04

On 2011-05-06 19:43, Krister Hallergard wrote:

Thanks Douglas. First I uninstalled lirc-modules-source.  Now realize that I should not have installed it on the fresh install - sorry Jarod!
Then I tried all the protocols and reconfirmed that only the RC-5 works.  Still only get scancodes and no keycodes, and after applying "ir-keytable -c -w /lib/udev/rc_keymaps/haupp" I do not get any scancodes either.  (yes, have copied the file lircd.conf.devinput to /etc/lirc/lircd.conf)
Cheers, Krister
Hi Krister,

It would appear that setting a keytable changes the protocol:

I am guessing that you had scancodes when you had the RC-5 protocol and then loaded the haupp keytable which probably set the protocol to other/none and that's how you lost the scancodes. I am also guessing that if you switch the keytable and then force the protocol back to RC-5 you might get both.


Hi Douglas,

You are quite right!  This solved my problem, and I can still use my old /etc/lirc/lircd.conf and my old ~/.lircrc.  Great, thanks a lot

Cheers Krister