Can't figure out how to track down this bug.  Any ideas would be _really_ appreciated.

Symptom: I get repeated events from the remote with count of '00'  It only happens with mythfrontend running and connected to lirc.

How it happens:

in the following I have 'irw' and 'mythfrontend' running.  I press the CH - button on the remote wait 1-2 seconds and then hit the 'enter' key in the keyboard to add the newline.  Here's the output from 'irw':

00000000000017e1 00 Ch- hauppauge_pvr

00000000000017e1 00 Ch- hauppauge_pvr
00000000000017e1 01 Ch- hauppauge_pvr

00000000000017e1 00 Ch- hauppauge_pvr
00000000000017e1 00 Ch- hauppauge_pvr   <---- Here it is!

00000000000017e1 00 Ch- hauppauge_pvr
00000000000017e1 01 Ch- hauppauge_pvr

00000000000017e1 00 Ch- hauppauge_pvr
00000000000017e1 01 Ch- hauppauge_pvr
00000000000017e1 00 Ch- hauppauge_pvr  <---- and here.

The problem is not the 'repeat' because of the '00' count, it won't catch it.  I also tried the 'delay' feature in the .lirc file, but the '00' count fools it too.

Also, it doesn't happen if I shutdown mythfrontend, or if I restart lircd while mythfrontend is running (so the frontend won't listen to it)

My system: three cards pvr 150, 250 and a 350.  not using the tv-out of the pvr-350.  tried both the ir inputs for the 250 and the 350.  Tried pulling out all but one of the cards.  Tried older lirc versions (running the CVS copy currently)
Also tried 4 or 5 different lircd.conf files and three different remotes.

Please help me out...  I've no idea what to try next.


-jose-

in case somebody is interested:
mythtv 0.20.2-0ubuntu10.1
linux 2.6.22-14-generic
ivtv:  version 1.0.0 (2.6.22-14-generic SMP mod_unload 586 )
lirc-0.8.3pre1 (but tried others)


Jose Rubio
www.TriangleResidential.com
O: 919-846-3208
C: 919-818-2342
jose@TriangleResidential.com