Hi !

Now irrecord works, but I've a gap error :s...
So to summarize :

I run Ubuntu Feisty, with kernel 2.6.20-16-generic (current kernel of Ubuntu). I've compiled lirc with source (lirc-0.8.2). I configure it to use the dev/input driver, because I can't have the /dev/hiddev file. My remote IR is on /dev/input/event1. I run irrecord with :

sudo irrecord -H dev/input --device=/dev/input/event1 test.file

When I press some button (more than 1 second), it produced some dot :

Hold down an arbitrary button.

But finally i've :

irrecord: gap not found, can't continue
irrecord: closing '/dev/input/event1'

So, I think i'm in the right way, but I don't know what to do know.

Thanks for your help

2007/7/27, Loc Dardant < loic.dardant@gmail.com>:

2007/7/27, Tino Keitel <tino.keitel+lirc@tikei.de>:
On Fri, Jul 27, 2007 at 15:01:28 +0200, Loc Dardant wrote:
> 2007/7/27, Tino Keitel <tino.keitel+lirc@tikei.de >:


> The device should also show up in the kernel log:
> >
> > hiddev96: USB HID v1.11 Device [Apple Computer, Inc. IR Receiver] on
> > usb-0000:00:1d.3-2
> >
> > I could also be the case that the Apple IR blacklist entry is in your
> > kernel, as the version number (2.6.20-16-generic) indecates that it is
> > not a source from www.kernel.org .
> If you tell me how find if it the case, I will find, but if you don't
> have enough time I will google it later today
> Thanks to you again

If it doesn't show up in the kernel log, then it is likely

Maybe you just have to load the usbhid module, if it is not yet loaded
in your system.

With a  modprobe usbhi, the /dev folder is the same, nothing appear...

I've too this :
loic@loic-desktop:/dev$ dmesg | grep hid
[   14.316000] usbcore: registered new interface driver hiddev
[   14.492000] drivers/usb/input/hid-core.c: couldn't find an input interrupt endpoint
[   14.504000] usbcore: registered new interface driver usbhid
[   14.504000] drivers/usb/input/hid-core.c: v2.6:USB HID core driver
[   80.496000] usb 4-1: usbfs: USBDEVFS_CONTROL failed cmd hid2hci rqt 64 rq 0 len 0 ret -84


This SF.net email is sponsored by: Splunk Inc.
Still grepping through log files to find problems?  Stop.
Now Search log events and configuration files using AJAX and a browser.
Download your FREE copy of Splunk now >>  http://get.splunk.com/

Loc Dardant

Loc Dardant