2007/7/27, Tino Keitel <tino.keitel+lirc@tikei.de>:
On Mon, Jul 23, 2007 at 22:27:49 +0200, Loc Dardant wrote:
> Hello all !
> I've got a problem with irrecord, he don't run :). So :
> I've installed lirc from package (on ubuntu), it's approximatively version
> 0.8.1. next I try to run irrecord but he says to me :

Hi !

With lirc 0.8.1, you have to patch the kernel to add the appleir driver
(see the patchset somewhere at http://www.mactel-linux.org). Then the
Apple IR device becomes an input device, so you have to use the
dev/input driver with irrecord. The device file is the event device in
/dev/input/. The lsinput command shows you what device belongs to the
Apple IR.

With lirc 0.8.2, there is a macmini driver available, so you don't need
the appleir kernel driver. The device you use with lirc (and irrecord)
is the HID-device for the Apple IR in /dev/usb/. However, kernels since
2.6.21 and above have the Apple IR blacklisted in the HID driver (see
the thread at
So you have to patch your kernel to get a hiddev for the Apple IR.

Thanks for the view of the problem. I try to compile lirc 0.8.2 with my  2.6.20-16-generic kernel. No problem at all, with the macmini driver (during installation). But I can't find which device I must use with irrecord. How to find it ?



This SF.net email is sponsored by: Splunk Inc.
Still grepping through log files to find problems?  Stop.
Now Search log events and configuration files using AJAX and a browser.
Download your FREE copy of Splunk now >>   http://get.splunk.com/

Loc Dardant