Hi,

I patched my linux kernel to make the Kworld 110/115 remote work with linux.
When the system starts up the lirc_dev driver is loaded (which I think is the devinput driver).


The system detects the card, detects the remote and makes an interface for it in /dev/input as event4.

Not knowing if my config worked (irw returned nothing when testing) I decided to try and record a config file.
So I run irrecord:
irrecord --driver=devinput --device=/dev/input/event4 ./testconfig.conf

After running this command it prompts for any button on the remote to be pressed.
I then get this error:
irrecord: gap not found, can't continue
irrecord: closing '/dev/input/event4'

Any suggestions/help for getting this to work would be very much appreciated.

Some info:

From /proc/bus/input/devices
I: Bus=0018 Vendor=0000 Product=0000 Version=0000
N: Name="i2c IR (Kworld ATSC"
P: Phys=i2c-0/0-0030/ir0
S: Sysfs=/class/input/input4
U: Uniq=
H: Handlers=kbd event4
B: EV=100003
B: KEY=c0300 10200000000000 0 2040000 1b880000001 1e168000000000 1400f50140ffe

From dmesg:
input: i2c IR (Kworld ATSC as /class/input/input4
ir-kbd-i2c: i2c IR (Kworld ATSC detected at i2c-0/0-0030/ir0 [saa7133[0]]

KnyghtMare