Quoting Douglas Pearless <Douglas.Pearless@pearless.co.nz>:

> Hmm,
> This could explain why my MCEUSB remote stopped working when I moved to
> 2.6.37-rc3.
> Cheers
> Douglas.
> On 16/11/2010 5:46 p.m., Jarod Wilson wrote:
>> On Nov 6, 2010, at 8:13 PM, Damjan Marion wrote:
>>> Hi,
>>> I tried to compile 2.6.37-rc1 kernel from git on my Ubuntu Maverick
>>> where I have XBMC and MS remote. Kernel is configured based on
>>> /boot/config-2.6.35-22-generic, which is standard kernel coming on
>>> maverick.
>>> After reload with new kernel, only remote controller arrow keys are
>>> working and all other keys are not working.
>>> Downgrading back to 2.6.35-22 fixes this issue.
>>> Is this a known issue? Any idea how to fix it?
>> Already fixed, just not pushed along to Linus' tree yet.
>> Actually, not sure if its even merged in the v4l-dvb tree
>> just yet. Should be sooner or later though (ideally, before
>> 2.6.37 final, obviously).
>> See
>> http://git.kernel.org/?p=linux/kernel/git/jarod/linux-2.6-ir.git;a=shortlog;h=refs/heads/staging
>> I believe it broke in this commit:
>> http://git.kernel.org/?p=linux/kernel/git/jarod/linux-2.6-ir.git;a=commitdiff;h=fdb453f31fc0ca2fa2e10ce2406991ff83dafbf3
>> But is repaired by this one:
>> http://git.kernel.org/?p=linux/kernel/git/jarod/linux-2.6-ir.git;a=commitdiff;h=3873d67013ea83df879fc750e65b93e055df7853
>> Of course, in between the two of those, you have the ir-core to
>> rc-core rename and interface change patches to contend with...
> ------------------------------------------------------------------------------
> Increase Visibility of Your 3D Game App & Earn a Chance To Win $500!
> Tap into the largest installed PC base & get more eyes on your game by
> optimizing for Intel(R) Graphics Technology. Get started today with the
> Intel(R) Software Partner Program. Five $500 cash prizes are up for grabs.
> http://p.sf.net/sfu/intelisp-dev2dev
Would it be possible for you to identify when the fixes appear in the kernel on http://kernel.org/ I have tried to figure it out by looking at the changelog for snapshot: 2.6.37-rc3-git5    and I cannot see it, I am keen to apply the relevant patch and try it.