When you compiled lircd did you use --with-driver=dvico or perhaps --with-driver=all on the ./configure line?  
did you accidentially leave conflicting versions of lirc installed (eg the RPM version, and a self-compiled version?) - if so, un-install any RPM/deb version/s before recompiling and reinstaling again.
can you tell me the exact command line you used to run lircd ?   
did you use ...
--device=/dev/hiddev0  (or /dev/usb/hiddev0, or wherever your remote device file is located for your linux version)
-n  (so you can see any output?)
does your lircd.conf look like the one below?

# Please make this file available to others
# by sending it to <lirc@bartelmus.de>
# this config file was automatically generated
# using lirc-0.7.3-CVS(dvico) on Thu Sep  1 21:36:06 2005
# contributed by: David Bussenschutt <buzz@oska.com>
# brand:     "DViCO"  
# model no. of remote control:  "Fusion Remote MCE"    
# devices being controlled by this remote: My MythTV install
begin remote
  name  DViCO
  bits            8
  eps            30
  aeps          100
  one             0     0
  zero            0     0
  pre_data_bits   48
  pre_data       0x100460000
  post_data_bits  8
  post_data      0xFE
  gap          195843
  toggle_bit      0

      begin codes
          ok                       0x5e
          up                       0x51
          down                     0x53
          left                     0x5B
          right                    0x5F
          setup                    0x16
          tv_onoff                 0x46
          guide                    0x0A
          dtv                      0x02
          mp3                      0x0E
          dvd                      0x1A
          cpf                      0x1E
          back                     0x49
          more                     0x59
          dvd_menu                 0x4D
          alt_tab                  0x55
          replay                   0x0F
          skip                     0x12
          start                    0x42
          vol_up                   0x15
          vol_down                 0x05
          ch_up                    0x11
          ch_down                  0x09
          photo                    0x52
          live                     0x5A
          folder                   0x19
          1                        0x0B
          2                        0x17
          3                        0x1B
          4                        0x07
          5                        0x50
          6                        0x54
          7                        0x48
          8                        0x4C
          9                        0x58
          0                        0x03
          ratio                    0x13
          zoom                     0x1F
          rew                      0x43
          playpause                0x47
          ff                       0x4F
          mute                     0x57
          stop                     0x0D
          rec                      0x01
          power_onoff              0x4e
      end codes
end remote



From: lirc-list-admin@lists.sourceforge.net [mailto:lirc-list-admin@lists.sourceforge.net] On Behalf Of absoludity (sent by Nabble.com)
Sent: Wednesday, 21 December 2005 10:57 PM
To: lirc-list@lists.sourceforge.net
Subject: Re: RE: Unable to get UltraView (Dvico ) remote working

Hi Buzz, hi Nick,

First... THANKYOU! I've spent all of today trying to figure out why my DVICO remote won't work...now I know there's more than one remote with the FusionHDTV's!

Second... I got really excited when I found this thread, and tried the new lircd.conf, but it's still not working, so I was wondering if any of you might be able to suggest something?

I'm running a Myth frontend  (0.18.1) on Ubuntu Dapper using the Fusion MCE remote. My situation is exactly like Nick's in that I can cat /dev/hiddev0 and see output when I press buttons. irrecord behaves as outlined by Nick and irw doesn't want to budge with any information.

I've tried irw together with lirc 0.7.2, 0.7.0, and 0.8.0pre2 using David's (Buzz's) lircd.conf (the third 'begin remote')... according to Nick, this should have worked with 0.7.2?

Any ideas for how I can troubleshoot this?

TIA, Michael

Sent from the LIRC forum at Nabble.com:
Re: RE: Unable to get UltraView (Dvico ) remote working