On Thu, Jun 18, 2009 at 10:02 AM, Jarod Wilson <jarod@wilsonet.com> wrote:
On Jun 18, 2009, at 10:45 AM, mike dehart wrote:

I'm using this on an ubuntu box (XBMC Live in fact).  The receiver works flawlessly, but irsend will not transmit.  irsend is aware of the device and can list its codes:
...

but if i run any irsend command to transmit, the talkback LED doesn't flash (i have confirmed the talkback does work with another device) and nothing is sent.  i've even tried setting the transmitter

here is the lsusb output:

Bus 001 Device 003: ID 13fe:3100 Kingston Technology Company Inc.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 002: ID 1784:0008 TopSeed Technology Corp.


Hm... Okay, so its one of the topseed devices that was already in the transmitter_mask_list[] in the driver, which denotes that we think its transmitter mask is not inverted like it is on the bulk of other receivers. Perhaps that's wrong for this device. I'd try rebuilding lirc_mceusb2 from lirc cvs with the entry for your device in the transmitter_mask_list commented out.


--
Jarod Wilson
jarod@wilsonet.com






every time i run configure i get the following message:

miked@miked-ubuntu-vm:~/xbmc/lirc/lirc$ ./configure --with-moduledir=/lib/modules/2.6.24-19-generic/misc --with-x --with-driver=mceusb2 --with-major=61 --with-port=none -with-irq=none
configure: error: cannot find install-sh or install.sh in "." "./.." "./../.."
miked@miked-ubuntu-vm:~/xbmc/lirc/lirc$

-mike