Oops I wasn't aware that I was only replying to you. I just hit reply in gmail....

Well how do you start udev logging and what should I look for.  Until now I just assumed that if it said my pvr card was supported for remotecontrol then that wold mean to usb-reciever that came with the card. Is there another product that I haven't heard about that allows yoo to plug an IR-reciever directly to a winTV-PVR-150 card?
I look into the other points you mentioned when I get a chance.


2006/2/4, Nick <knowledgejunkie@gmail.com>:
On 04/02/06, Hans Harhoff Andersen <hansharhoff@gmail.com > wrote:
> This is my lirc logfile:
> Feb 2 20:07:08 eruantalon lircd: lircd(hauppauge) ready
> Feb 2 20:07:30 eruantalon lircd: accepted new client on /dev/lircd
> Feb 2 20:07:30 eruantalon lircd: could not get file information for
> /dev/lirc
> Feb 2 20:07:30 eruantalon lircd: default_init(): No such file or directory
> Feb 2 20:07:30 eruantalon lircd: caught signal
> This repeated as many times as I've tried to use irw and lircd.
> I am using udev for device creation, but the /dev/lirc device first showed
> when i ran make install from the lirc source directory.
> What does this mean? Is the current version of /dev/lirc a pointer to
> nothing. It seems to disappear every time I reboot. Does this mean that udev
> is not findeing the right device or what? How do I go about finding out
> wether the kernel recognizes my hauppauge remote control?


The lirc_i2c module is for running the IR receiver plugged directly
into the PVR card, not via USB as far as I know. Maybe you need a
different module to support the USB-based receiver? Perhaps this is
why LIRC is not creating the /dev/lirc device - because it cannot find
a device attached to the PVR card?

The only additional things I can think of are:

i) ensure you have a valid /etc/lircd.conf file ( the remote definition)
ii) enable udev logging to determine whether the kernel is seeing the
LIRC devices when the modules are being loaded
iii) check your udev rules and create a udev symlink between
/dev/lirc0 and /dev/lirc
iv) ensure that the USB receiver is supported under LIRC and the
correct module is being loaded?

Other than that, I would post again back to the list and see if any
other Kubuntu users have had the same problems with 0.8. I've CC'd
this reply to the list just in case.