Hello Aaron,

there are two ways to access the card through the driver lirc_gpio or the devinput  http://linux.bytesex.org/v4l2/faq.html#lircd

the iIR remote should be supported by the cx88 with recent kernel driver for the TV card.

make sure the module is loaded
#lsmod |grep cx88

have a look in /proc/bus/input/devices and see if you can see your input device.

in my case:
I: Bus=0001 Vendor=107d Product=665f Version=0001
N: Name="cx88 IR (WinFast DTV1000-T)"
P: Phys=pci-0000:06:00.0/ir0
S: Sysfs=/devices/pci0000:00/0000:00:1e.0/0000:06:00.0/input/input5
U: Uniq=
H: Handlers=kbd event5 
B: EV=100003
B: KEY=10afc336 2150a4800000000 0 40480010007 8000019000004801 1e000000004400 10000010000ffc

This tells you that the remote control is accessible on event5 -> /dev/input/event5

you can run  
#evtest /dev/input/event5 
press some keys and to see if it is working.

after that you need to get the lircd.conf 
http://linux.bytesex.org/v4l2/faq.html#lircd

now run

#/usr/sbin/lircd -H dev/input -d /dev/input/event5

#irw

see if you can see the key strokes.

from here you get one to configure the .lircc config files to bind the keys to instructions you wish then to have.

if you find that your IR  is a bit sluggish you may improve the responsiveness by changing  Processor type and features -> Timer frequency (1000 HZ) in  the xconfig and recompiling the kernel.

I found by setting the Timer frequency to 1000HZ the serial and the tvcard ir   responded much better.

I hope that helps.

Stefan




On 25/03/2009, at 8:04 PM, Aaron Whitehouse wrote:

Hello,

I'm sorry to bother you all with a support question, but I have really
tried hard to answer my problem with guides on the web and just can't
get there.  Mythbuntu pretends to have a configuration utility for my
remote (Mythbuntu-control-center), but it doesn't help me either.

I have a bttv 34 Winfast 2000XP card and Mythbuntu 8.10.  The number
keys (0-9), enter key, suspend key and various other keys on my remote
work as if I had hit the corresponding keys on the keyboard.
Unfortunately, the cursor keys on the remote double as channel/volume
keys and don't work as cursor keys on a keyboard.  That is a shame as I
would be more than happy just to have enter and the cursor keys working.

irw, mode2, irrecord and LIRC all do not work.

I found some information on the Internet that said the remote was being
detected as a keyboard and that I had to add a hal rule to stop this
happening before LIRC would work, as hal was capturing things before
they could get to LIRC:
http://ubuntuforums.org/archive/index.php/t-1050558.html

Using that, I wrote a rule and stopped the remote being detected as a
keyboard.  Unfortunately, that didn't help me get LIRC working.  I have
followed various guides on the Internet, but none have worked for me.
When I sudo dpkg-reconfigure lirc and choose my card (it is in the
list), it can't start LIRC.  When I look in /dev/, there is no
/deb/lirc, /dev/lircd, /dev/lirc/0 or anything remotely similar.

I tried asking a question on Ubuntu first:
https://answers.launchpad.net/mythbuntu/+question/54983
but, as nobody has been able to help me, I am hoping someone on this
list can steer me in the right direction.

Thanks in advance,

Aaron

------------------------------------------------------------------------------
Apps built with the Adobe(R) Flex(R) framework and Flex Builder(TM) are
powering Web 2.0 with engaging, cross-platform capabilities. Quickly and
easily build your RIAs with Flex Builder, the Eclipse(TM)based development
software that enables intelligent coding and step-through debugging.
Download the free 60 day trial. http://p.sf.net/sfu/www-adobe-com