On 2011-05-06 19:43, Krister Hallergard wrote:
Thanks Douglas. First I uninstalled lirc-modules-source.  Now realize that I should not have installed it on the fresh install - sorry Jarod!
Then I tried all the protocols and reconfirmed that only the RC-5 works.  Still only get scancodes and no keycodes, and after applying "ir-keytable -c -w /lib/udev/rc_keymaps/haupp" I do not get any scancodes either.  (yes, have copied the file lircd.conf.devinput to /etc/lirc/lircd.conf)
Cheers, Krister
Hi Krister,

It would appear that setting a keytable changes the protocol:

I am guessing that you had scancodes when you had the RC-5 protocol and then loaded the haupp keytable which probably set the protocol to other/none and that's how you lost the scancodes. I am also guessing that if you switch the keytable and then force the protocol back to RC-5 you might get both.


Hi Douglas,

You are quite right!  This solved my problem, and I can still use my old /etc/lirc/lircd.conf and my old ~/.lircrc.  Great, thanks a lot

Cheers Krister

So I replaced the minimal fresh install with the backup copy of the upgrade from 10.10 to 11.04.  Uninstalled the lirc-kernel-source, got rid of hareware.conf, the irremote hack and the old kernel.  Applied a script to start /usr/sbin/lircd before start of KDM and in Autostart these scripts: 

#! /bin/sh
sudo ir-keytable -c -w /lib/udev/rc_keymaps/haupp
sudo ir-keytable --protocol=RC-5
sudo rm /var/run/lirc/lircd.pid
sudo /usr/sbin/lircd -H dev/input -d /dev/input/event6 -n

#! /bin/sh
/bin/sleep 1
killall irexec
killall irxevent
irxevent -d
irexec -d

This worked very well, and I am so pleased as I could keep the old /etc/lirc/lircd.conf and ~/lircrc.  However, there is still one problem:  the lirc mouse.  I used to start it with this script, but it does not work anymore:

#! /bin/sh
/bin/sleep 5
sudo modprobe uinput
sudo /usr/sbin/lircmd --uinput

I understand there is a change but have not understood what I should do.  To apply "/usr/sbin/lircmd# instead of the above script does create /var/run/lirc/lircm but the mouse does not function either.

Cheers,  Krister