i spent the last 3 days trying to get the Remote Controll and IR-Reciver thats on the Kanam / Accent Cases to work.
and i failed till now.. so i think its ok to ask the list for help...
first try was with the RPMīs under Mandrake 9.1 but i dont managed it to get even the basic lirc to work..
so i switched to Redhat 9 and installed again the RPMīs this time lirc was working. right out of the box...
i even could do a irrecord.. i pressed the buttons as descripte and after i was finished the file
looked like this
begin remote
  name  1htpctest
  bits            0
  eps            30
  aeps          100
  one             0     0
  zero            0     0
  pre_data_bits   8
  pre_data       0x0
  gap          189978
  min_repeat      23
  toggle_bit      7

      begin codes
          Close                    0x0000000000000000
          Number1                  0x0000000000000000
          Eject                    0x0000000000000000
          Winamp                   0x0000000000000000
      end codes
end remote
see the 0x0000000000000000?
every line ist the same ;(
so then i startet a WindowsXP on the same maschine and installed the winlirc...
i started the software and nothing happend.
than i switched the winlirc software from DCD device to RX device and voila
it worked at 115.000 Baud...
i was abel to generate a irrecord file under windows it looked like this
# this config file was automatically generated
# using WinLIRC 0.6.4 (LIRC 0.6.1pre3) on Tue Jul 15 10:47:49 2003
# contributed by
# brand:             htpc-remote
# model:
# supported devices:
begin remote
  name  htpc-remote
  bits           16
  flags SPACE_ENC
  eps            25
  aeps          100
  header        300  4934
  one           300  1017
  zero          300  2136
  ptrail        300
  repeat        300  2770
  pre_data_bits   16
  pre_data       0xFE01
  gap          48930
  toggle_bit      0

      begin codes
          Button1                  0x000000000000EF10
          Button2                  0x0000000000006F90
          Button3                  0x000000000000AF50
          Button4                  0x000000000000F708
          Button5                  0x0000000000007788
          Button6                  0x000000000000B748
          Button7                  0x000000000000E718
          Button8                  0x0000000000006798
          Button9                  0x000000000000A758
          Button0                  0x0000000000007D82
          Eject                    0x000000000000BF40
          Start                    0x000000000000FD02
          PullDown                 0x0000000000009F60
          VolumeDown               0x0000000000000FF0
          VolumeUp                 0x0000000000008F70
          ESC                      0x0000000000005FA0
          Close                    0x0000000000001FE0
          Prev                     0x000000000000CF30
          Next                     0x0000000000007F80
          ArrowUp                  0x0000000000002FD0
          ArrowDown                0x0000000000003DC2
          ArrowLeft                0x0000000000003FC0
          ArrowRight               0x00000000000027D8
          Enter                    0x00000000000037C8
          Mute                     0x0000000000004FB0
          Step                     0x000000000000DF20
          PlayPause                0x0000000000006D92
          Stop                     0x000000000000ED12
          Winamp                   0x0000000000008778
          MediaPlayer              0x00000000000057A8
          hdtv                     0x00000000000017E8
          cdplayer                 0x0000000000009768
          windv                    0x000000000000DD22
          powerdvd                 0x000000000000D728
          internet                 0x0000000000009D62
          email                    0x0000000000001DE2
          Free1                    0x0000000000005DA2
          Free2                    0x00000000000047B8
          Free3                    0x000000000000C738
          Free4                    0x00000000000007F8
      end codes
end remote
so... happy i taked the file back to linux and hoped all problemw are now solved.. but they arent..
it dosent work under linux...
So i get a CVS snapshot and tryed to find the RX device switch.. but had no luck.
i also tryed to use the winlirc file as a template for irrecord but dident work...
compiling of lirc dident work also.. i think lirc can only be compiled if i had a  self compilied kernel or someting like this...
So Question to the list...
How can i make the Config File from Winlirc working under lirc?
Where can i set the RX - DCD device thing?
Where can i set the Baud Rate?
very very thx for any help...
im realy lost...
greetings from munich-->bavaria-->germany-->europe
peter vogel