I have an interesting issue with lirc.  When I reboot lircd is not started, so I run service lircd restart and it says [OK] then I run irw and immediately get a prompt and I check status of lircd and it says it’s dead.  So I restart it and the same thing happens, unless I run modprobe lirc_i2c, then everything is fine.  As far as I can tell I am running lirc after my ivtv setup in modprobe.conf.  I am using the IR port on Hauppage PVR-250 with FC6 installed and 2.6.18-1.2868.fc6.


Here is my modprobe.conf:


alias eth0 e100

alias scsi_hostadapter ata_piix

alias char-major-61 lirc_i2c

alias char-major-81 videodev

alias char-major-81-0 ivtv

alias char-major-81-1 ivtv

alias char-major-81-1 ivtv

alias char-major-116 snd

alias snd-card-0 snd-intel8x0

alias char-major-14 soundcore

alias sound-slot-0 snd-card-0

alias sound-service-0-0 snd-mixer-oss

alias sound-service-0-1 snd-seq-oss

alias sound-service-0-3 snd-pcm-oss

alias sound-service-0-8 snd-seq-oss

alias sound-service-0-12 snd-pcm-oss

alias char-major-195 nvidia-1_0-8776

alias nvidia nvidia-1_0-8776

install lirc_i2c /sbin/modprobe ivtv; /sbin/modprobe --ignore-install lirc_i2c


and there are no lirc lines in dmesg after reboot, after modprobe lirc_i2c:

lirc_dev: IR Remote Control driver registered, at major 61

lirc_i2c: chip found @ 0x18 (Hauppauge IR)

lirc_dev: lirc_register_plugin: sample_rate: 10



Any ideas?