Bambo CTL-460

Help
Jeremy
2010-03-29
2013-04-05
  • Jeremy

    Jeremy - 2010-03-29

    Hey all, I've been trying to get a Bamboo Pen CTL-460 (ID 056a:00d4 Wacom Co., Ltd) to work on my linux box for about a week now.  I've tried every thing I've come across using google to no avail. I can't even get HAL or UDEV to create /dev/input/wacom.  All I have is /dev/input/event which I think corresponds to the various wacom inputs, but I'm not sure.  Neither the wacom driver nor the usb subsystem seems to want to claim it:

    # more /proc/bus/usb/devices
    T:  Bus=02 Lev=02 Prnt=02 Port=07 Cnt=02 Dev#=  5 Spd=12  MxCh= 0
    D:  Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs=  1
    P:  Vendor=056a ProdID=00d4 Rev= 1.06
    S:  Manufacturer=Wacom Co.,Ltd.
    S:  Product=CTL-460
    C:* #Ifs= 2 Cfg#= 1 Atr=80 MxPwr= 98mA
    I:* If#= 0 Alt= 0 #EPs= 1 Cls=03(HID  ) Sub=01 Prot=02 Driver=(none)
    E:  Ad=81(I) Atr=03(Int.) MxPS=   9 Ivl=4ms
    I:* If#= 1 Alt= 0 #EPs= 1 Cls=03(HID  ) Sub=00 Prot=00 Driver=(none)
    E:  Ad=82(I) Atr=03(Int.) MxPS=  64 Ivl=4ms

    I've tried adding the vendor:id to the fdi files, I've tried the linuxwacom-0.8.4-4 driver, the linuxwacom-0.8.5-11 driver, and I'm currently using the xf86-input-wacom-0.10.5 driver and all have done pretty much the same thing. I've tried a lot of stuff so if someone is willing to help me, please let me know what information would be relevant to help solve this issue. I just don't want to post 2 pages of useless info. Here is some general info that may be of help:

    Distro: Gentoo Linux<- I know this might put some people off, but I've tried all the Gentoo how-to's and don't think its a Gentoo specific problem. I think its something stupid I'm doing and I just need a nudge in the right direction.

    Kernel: 2.6.32
    Udev: 149
    HAL: 0.5.14-r2
    X-Server: 1.6.5-r1

    Thanks a bunch to anyone who might have any suggestions.

     
  • Jeremy

    Jeremy - 2010-04-05

    Couldn't figure out how to edit the original title so I'll just mark it SOLVED in my reply here.

    I finally came across this post after more hours of searching and trying stuff:

    http://ubuntuforums.org/showpost.php?p=8283168&postcount=1

    The part that helped me was this:

    sudo cp src/2.6.27/wacom.ko /lib/modules/$(uname -r)/kernel/drivers/input/tablet/
    sudo depmod -a

    The line in bold is the one that did it.  (except I used the module from src/2.6.30/).  For some reason, while reading through the linuxwacom documentation, I was under the impression that the make install portion of the build process would overwrite the module that gets built by the kenel with the one built by the linuxwacom source automatically. Obviously I was wrong, or not doing something right. After copying the wacom.ko from the source tree and replacing the kernel built one, I reloaded the wacom module and voila! there was suddenly a /dev/input/wacom and the tablet started working immediately.

    I knew is there was something stupid that I was doing-or in this case misunderstanding.

    So thanks again, it works now :-)

     
  • Jeremy

    Jeremy - 2010-04-05

    One more thing I forgot in case anyone cares.  I had scrapped the xf86-input-wacom-0.10.5 and was using the latest linuxwacom-0.8.5-12 source when i got it working.  Not sure if it would work by doing the same thing with the xf86-input version.

    Later

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks