#229 xf86-input driver versions above 0.17.0 : no right-click + unexpected cursor behaviour

closed-works-for-me
nobody
None
2015-12-04
2013-05-17
charlie6
No

Hi,
here on PuppyLinux Wheezy kernel 3.5.2 + Xorg 1.12, have compiled xf86-input driver 0.15.0 and above:
All is OK up to version 0.17.0 (this last included);
not tested: 0.18.0 and 0.19.0;
On later versions 0.20.0 and 0.21.0, i encountered the following:
1. the mouse cursor does not move as expected: when stylus is lifted far away from the tablet pad, then the mouse-cursor moves to the upper-left display corner or upper-up side of the corner; here cannot get the cursor to stay were it was before lifting the stylus...(xorg.conf setup on "Relative").
2. i am using a Bamboo-pen MTE-450; right and left click are integrated in the pens -or stylus - button. Now, with 0.20.0 and 0.21.0 drivers, i have no right-click function. Only the left-click.

All this trials have been performed with Linux running on a fresh installed session; using the same wacom options in xorg.conf.

Thanks in advance for any advice.
Charlie

Related

Bugs: #229

Discussion

  • Ping Cheng
    Ping Cheng
    2013-06-06

    I can not reproduce the issue on Ubuntu 13.04 with MTE-450.

     
  • charlie6
    charlie6
    2013-06-07

    Hi Peng,
    thanks for your reply !

    I also get the same behaviour with an old Volito + pen + mouse.
    So editing the Options "Absolute" or "Relative" seems having no effect.

    All went good before version 0.18.0.
    I have been using the same /etc/X11/xorg.conf for months without issue.

    I have red there is another setting than /etc/X11/xorg.conf. Do i have to
    change that setting?

    thanks for any reply

    Charlie

    I can not reproduce the issue on Ubuntu 13.04 with MTE-450.


    [bugs:#229] xf86-input driver versions above 0.17.0 : no right-click +
    unexpected cursor behaviour

    Status: open
    Created: Fri May 17, 2013 04:08 PM UTC by charlie6
    Last Updated: Fri May 17, 2013 04:08 PM UTC
    Owner: nobody

    Hi,
    here on PuppyLinux Wheezy kernel 3.5.2 + Xorg 1.12, have compiled
    xf86-input driver 0.15.0 and above:
    All is OK up to version 0.17.0 (this last included);
    not tested: 0.18.0 and 0.19.0;
    On later versions 0.20.0 and 0.21.0, i encountered the following:
    1. the mouse cursor does not move as expected: when stylus is lifted far
    away from the tablet pad, then the mouse-cursor moves to the upper-left
    display corner or upper-up side of the corner; here cannot get the cursor
    to stay were it was before lifting the stylus...(xorg.conf setup on
    "Relative").
    2. i am using a Bamboo-pen MTE-450; right and left click are integrated in
    the pens -or stylus - button. Now, with 0.20.0 and 0.21.0 drivers, i have
    no right-click function. Only the left-click.

    All this trials have been performed with Linux running on a fresh
    installed session; using the same wacom options in xorg.conf.

    Thanks in advance for any advice.
    Charlie


    Sent from sourceforge.net because you indicated interest in
    https://sourceforge.net/p/linuxwacom/bugs/229/

    To unsubscribe from further messages, please visit
    https://sourceforge.net/auth/subscriptions/

    --
    ;-) Please ... if you happened to mail us a MS-Word document ( file.doc or
    file.docx ) -, would you mind to use formating it under the «Rich Text
    Format» (file.rtf) instead ...as the .rtf format is a more universal
    portability and exchange format !

    Voici notre nouvelle adresse mail:
    barewillysprl@euphonynet.be

    BARÉ Willy sprL
    rue du Gonoy, 114
    5640 Maison-Saint-Gérard
    mobile: +32 0474 780051
    fax: +32 071 798711

     

    Related

    Bugs: #229

    • Ping Cheng
      Ping Cheng
      2013-06-12

      Charlie,

      Please email me, directly to my email account, your /etc/X11/xorg.conf, /var/log/Xorg.0.log, /var/log/messages, and the output of "uname -a". I'll take a look.

       
  • Jason Gerecke
    Jason Gerecke
    2014-12-13

    • status: open --> closed-works-for-me
     
  • Jason Gerecke
    Jason Gerecke
    2014-12-13

    Both of these issues seem to result from an unexpected interaction between our driver and the generic "mouse" driver. As described in [bugs:#240], if you add Option "GrabDevice" "1" to each wacom InputDevice in /etc/X11/xorg.conf then both problems seem to be prevented.

     

    Related

    Bugs: #240

  • charlie6
    charlie6
    2014-12-16

    Hi Jason,
    a ton of thanks for having found this !!
    that's really, really great !
    I've now upgraded my xf86-input-wacom driver from version 0.17.0 to the
    just compiled latest 0.27.0 !
    And added Option "Mode" "Relative" to each wacom device in xorg.conf as
    also my favourite Option "Mode" "Relative".

    Works great !!

    Thanks again

    Charlie
    Baré Willy sprl

    • status: open --> closed-works-for-me
    • Comment:

    Both of these issues seem to result from an unexpected interaction between
    our driver and the generic "mouse" driver. As described in [bugs:#240], if
    you add Option "GrabDevice" "1" to each wacom InputDevice in
    /etc/X11/xorg.conf then both problems seem to be prevented.


    [bugs:#229] xf86-input driver versions above 0.17.0 : no right-click +
    unexpected cursor behaviour

    Status: closed-works-for-me
    Group: Production
    Created: Fri May 17, 2013 04:08 PM UTC by charlie6
    Last Updated: Fri May 17, 2013 04:08 PM UTC
    Owner: nobody

    Hi,
    here on PuppyLinux Wheezy kernel 3.5.2 + Xorg 1.12, have compiled
    xf86-input driver 0.15.0 and above:
    All is OK up to version 0.17.0 (this last included);
    not tested: 0.18.0 and 0.19.0;
    On later versions 0.20.0 and 0.21.0, i encountered the following:
    1. the mouse cursor does not move as expected: when stylus is lifted far
    away from the tablet pad, then the mouse-cursor moves to the upper-left
    display corner or upper-up side of the corner; here cannot get the cursor
    to stay were it was before lifting the stylus...(xorg.conf setup on
    "Relative").
    2. i am using a Bamboo-pen MTE-450; right and left click are integrated in
    the pens -or stylus - button. Now, with 0.20.0 and 0.21.0 drivers, i have
    no right-click function. Only the left-click.

    All this trials have been performed with Linux running on a fresh
    installed session; using the same wacom options in xorg.conf.

    Thanks in advance for any advice.
    Charlie


    Sent from sourceforge.net because you indicated interest in
    https://sourceforge.net/p/linuxwacom/bugs/229/

    To unsubscribe from further messages, please visit
    https://sourceforge.net/auth/subscriptions/

     

    Related

    Bugs: #229
    Bugs: #240