#5 udf_fs_sb.h needs version.h on 2.2.x

closed-fixed
None
5
2000-07-21
2000-06-23
Anonymous
No

version.h should probably be included in include/linux/udf_fs_sb.h, for the KERNEL_VERSION() macro to operate correctly on 2.2.x kernels. It dies with a 'parse error' when I try to build the kernel with the UDF filesystem headers in place.

This is on 2.2.17pre6, with agpgart, usb and supermount patches in place. I used the udf-0.9.2.1 source package to generate a diff.

Derrik Pates
dpates@dsdk12.net

Discussion

  • Brian W. Barrett

    I needed to do the same when building a 2.4.0-test1-ac22-classzone kernel, so it may not be exclusive to the 2.2 series. I ran into the same problem as Derrik and his suggestion solve my problem. I used the latest CVS (CDRW branch) .

     
  • Ben Fennema

    Ben Fennema - 2000-07-21
    • assigned_to: nobody --> bfennema
    • status: open --> closed-fixed
     
  • Ben Fennema

    Ben Fennema - 2000-07-21

    Fixed in cvs. Never noticed the problem cause I remove those KERNEL_VERSION checks when I build my patches.

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks