I’ve got a ATI Graphics Expression+ PC2TV (ATI MACH64/Rage II GT) and I finally got TV out to work. The perplexing thing was it’s boot up and you could see output on the TV (using composite out), but when asked for a video mode  it’s lose it after that. I played around with fbset, getting the monitor to do all kinds of funky things, but never a picture.  (I was playing with resolutions and timings) Oh, and I was using the Vesa driver


Then I went into include/linux/fb.h and made the default videomode’s timings as I wanted: 20330, 128, 32, 32, 8, 128, 5 (NTSC) which worked! Now I use mode 0x311 and I can get a picture. It seems that the pixclock is hardcoded to some non-NTSC compatible values.


I quickly tried to get the ATI driver working, but I never succeeded. The Vesa driver works, but to try a new setting, I have to re-compile and reboot.


But I’d like to have it easier to do, I feel that I hacked it up and that I’m doing something wrong. Can anyone give me some pointers? I’d like to see my screen in 768x576 resolution, but there is no vesa mode for that.