Maybe another segmentation fault.

  • GTrax

    GTrax - 2012-10-02

    Hi John and others.
    I use CAE Linux - it being Ubuntu 10.04LTS geared to CAD engineering.
    The Linsmith version here is 0.99.22.
    Machine is CPU i7-860 on Gigabyte GA-P55-UD6 with 8GB

    If one visits the Print->Print Preview route, and then you get one visit to Print only. Whether you print or not, the next click on Print triggers the segfault.

    Like you, I am not a "proper" programmer, but I can twist the arm of someone who is.
    If / when we figure it out, we will likely get back here with a fix.

    My regards

  • John Coppens

    John Coppens - 2012-10-02

    Hello Graham,

    Much of linSmith was written a long time ago, and I've since acquired more skills, ;-)
    Last time I modified the program was to make it more compatible with more modern versions of GTK, and one of the items to change was the print preview item.

    Could you run the program inside the debugger? Though probably you are using a package from the distribution, the program might have been compiled with sufficient information to get useful information:
    In a terminal window:
    gdb linsmith
    … Do what's necessary to cause the segfault …
    type 'bt' in gdb, and send me a copy.

    This is the first time _this_ particular problem has been reported

    Thanks for the report!

  • GTrax

    GTrax - 2012-10-06

    Hi John

    My attempt to run linsmith with the debugger did not work.

    graham@graham-desktop:~$ gdb linsmith
    GNU gdb (GDB) 7.1-ubuntu
    Copyright (C) 2010 Free Software Foundation, Inc.
    License GPLv3+: GNU GPL version 3 or later <>
    This is free software: you are free to change and redistribute it.
    There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
    and "show warranty" for details.
    This GDB was configured as "x86_64-linux-gnu".
    For bug reporting instructions, please see:
    Reading symbols from /usr/local/bin/linsmith…done.
    (gdb) quit

    linsmith just did not appear ??? :|

    I think the Ubuntu version may have been compiled without any debugging symbols at all,
    but I did think it should at least have started. I don't know what should have happened here.

    I also tried out printing a blank chart to a file (tried it twice, both PS and PDF)
    That goes OK, but then the very next visit to the File->Print also causes the immediate quit.

    I have now downloaded the source.  Before we start down the "its a bug" route, I think I should
    at least try and generate more information clues. I may need a little hand-holding here.
    Should I first remove the Ubuntu version, and install a compiled-from-source Linsmith, or should
    I leave the Ubuntu linsmith alone, and put the home-compiled executable somewhere else in the path,
    with a altered name?

    Perhaps to use something like  "make install -prefix=/home/graham/bin".

    For the present, let me explore this one a bit, so I can generate enough responses to at least yield
    a few clues as to what is going on. That Linsmith started some years ago does not diminish its usefulness.

    My apologies for the long wait between postings, but I am away much of the time.


  • GTrax

    GTrax - 2012-10-06

    Umm.. Sorry - I think I meant "  ./configure -prefix=/home/graham/linsmith"

  • John Coppens

    John Coppens - 2012-11-29

    Revisiting old mail, I came upon your problem, and I somehow didn't notice it. I frequently get
    loads of mails, but very rarely completely miss one… This is no excuse - please accept my

    In the debug session you valiantly started, I cannot see you actually started the program.

    Reading symbols from /usr/local/bin/linsmith...done. 
    (gdb) quit

    Instead of 'quit' you should enter the 'run' command to actually
    start the execution of linSmith. This extra step gives you the
    possibility to define stopping points in the code on beforehand

    About the correct way to install the compiled version - it's probably
    best to remove the Ubuntu version first, using one of the package
    managers, and then install the new one.

    If you'd rather install on top of the Ubuntu version, it's necessary to
    install really 'on top', i.e., replace the old executable by the new one.
    In most distributions, executables in /usr/local/bin get executed before
    the ones that come with a distro (which are normally in /usr/bin) - but
    there is no garantee. To know where the one is located that will be
    executed, you can type

    which linsmith

    in a terminal.

    Again, sorry for the delay in replying!



Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks