Trouble Installing Program

dvase
2006-12-14
2012-12-12
  • dvase

    dvase - 2006-12-14

    Hello,
    I am trying to install this program on Cygwin, but am running into a bit of trouble.

    I am able to run './configure' without much trouble, although I do get the warning:
    config.status: WARNING: po/Makefile.in.in seems to ignore the --datarootdir setting

    When the 'make --warn-undefined-variables' command is executed, it hangs after:
    Making all in src
    make[2]: Entering directory '/usr/linsmith-0.99.3/src'
    Makefile:240: warning: undefined variable 'CONFIG_STATUS_DEPENDENCIES'

    Please forgive me if the answer to this problem is obvious.  This is one of my first forays in using a Linux-like system and I am quite unfamiliar with its workings.

    Any suggestions would of great help, thanks,
    -Dustin

     
    • John Coppens

      John Coppens - 2008-05-24

      I am sorry I didn't see your problem before. Sourceforge used to forward messages to me,
      but this has stopped without warning.

      > am able to run './configure' without much trouble, although I do get the warning:
      > config.status: WARNING: po/Makefile.in.in seems to ignore the --datarootdir setting

      This is not a problem. There has been a change in autoconf.

      > When the 'make --warn-undefined-variables' command is executed, it hangs after:
      > Making all in src
      > make[2]: Entering directory '/usr/linsmith-0.99.3/src'
      > Makefile:240: warning: undefined variable 'CONFIG_STATUS_DEPENDENCIES'

      This error is new to me. I have the impression that you have some incompatibility problem with the automake/autconf tools you have installed (I believe they are version 1.9, which seems to have added the 'CONFIG_STATUS_DEPENDENCIES' variable.

      Try to run ./autogen.sh instead of ./configure (with the same options)
      If it doesn't work, send me the complete
        - config.log
        - output of the compilation
        - autoconf --version
        - automake --version
        - gcc --version
        - which distribution you are using

      and I'll see what I can do.

      John

       
      • dvase

        dvase - 2008-05-24

        Thanks for getting back to this error message, especially after so much time has passed!  Certainly unexpected.

        However, this issue is a moot point for me now; I've moved on to running a Linux system and rarely boot into Windows, as well as I no longer have Cygwin installed.

        I hate to hijack a thread, but I am having an issue with the latest version 0.99.6 of linsmith.  After compiling from source on a Ubuntu install, I am unable to add loads via the GUI buttons.  I can put numbers in the number fields (such as frequency and impedance) but the buttons "New" and "Update" to add the loads are grayed out and can't be pressed.  I've tried enabling the debugging output from the command line console but I've spotted nothing unusually.  Any ideas?

        Dustin

         
        • John Coppens

          John Coppens - 2008-05-24

          > Thanks for getting back to this error message, especially after so much time has passed!
          > Certainly unexpected.

          Hi Dustin,

          I normally reply immediately to any messages, but I have only recently detected that SF stopped sending me notices/copies of tracker mails. So I'm somewhat ashamed to admit that I didn't check the lists by hand. I sent a mail to the SF people and they pointed out that I have to enable that (the copies/notices) manually in the setup.

          Anyways. I did get the copy now ;-)    Congrats on your switching to Linux completely - I've donse so about 8 years ago. Never looked back.

          On the New/Update buttons:

          I thought I solved that problem with the 99.5 version or so. I just tried it again and it seems to work. Note that the 'New' or 'Update' buttons only get enabled if a valid and complete impedance is entered in the three fields (say 100 MHz, 12 Ohms and -23 jOhms)
          When typing the '2' of 23, the New button should enable.

          Could you try and do a fresh start, and enter those values in the fields?

          John

           
          • dvase

            dvase - 2008-05-24

            > I thought I solved that problem with the 99.5 version or so. I just tried it again and it seems to work. Note that the 'New' or 'Update' buttons only get enabled if a valid and complete impedance is entered in the three fields (say 100 MHz, 12 Ohms and -23 jOhms)
            > When typing the '2' of 23, the New button should enable.
            >
            > Could you try and do a fresh start, and enter those values in the fields?

            I did a fresh start and gave those values a try, but the "New" and "Update" buttons still stayed grayed out.

             
            • John Coppens

              John Coppens - 2008-05-24

              > I did a fresh start and gave those values a try, but the "New" and "Update" buttons still
              > stayed grayed out.

              That's strange. Just tried a large number of tests... No problem. Sorry to ask you -
              are you sure the version you're running is 0.99.6? (title bar, or About dialog)

              I've added a couple of lines to debug the input of load values. If you like, I'll send you
              a copy so you can run that. (I'd need your e-mail in that case. The Sourceforge mail system
              doesn't allow me to add attachments).

              John

               
              • dvase

                dvase - 2008-05-24

                > That's strange. Just tried a large number of tests... No problem. Sorry to ask you - 
                > are you sure the version you're running is 0.99.6? (title bar, or About dialog)

                I double checked the version number and it is 0.99.6

                > I've added a couple of lines to debug the input of load values. If you like, I'll send you
                > a copy so you can run that. (I'd need your e-mail in that case. The Sourceforge mail system
                > doesn't allow me to add attachments).

                I'll send the email address via private message as you suggested.

                 
    • John Coppens

      John Coppens - 2008-05-24

      If you'd like to send me your mail address, use a private message on SF.

      John

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks