lewinb - 2004-03-23

I'm posting this as a new thread, because it's a new problem, but it's still partially related to my other topic.  I appreciate any kind soul who will take the time to help with this!!

after having trouble with "no decode delegate" messages, I ran "convert -list format", and found that imagemagick was not able to read or write jpegs, even though I had installed jpeglib (or at least attempted to and failed) previously. Apparently, there was an error that I was unaware of when I installed it the first time, that prevented it from installing.
 
I downloaded the jpegv6 source again, and when I attempt to install it, it says that there are two problems.
 
1) ltconfig can't guess which kind of host it's on, and
 
2) it couldn't get libtool to work properly.
 
I tried changing the command to this:
 
[Bruce-Lewins-Computer:~/Desktop/jpeg-6b] lewinb% ./configure --enable-shared --host=UNIX
 
But it didn't make a difference:

checking host system type... Invalid configuration `unix': machine `unix' not recognized
 
Now, I *know* libtool is there, and is working. First, it said it wasn't even available, so I changed how the script called the command from "./libtool" to just "libtool". (For some reason, this is how things in the bin are loaded on mac OS... maybe it's the same on others?). Once I did that, it was able to run it.
 
When I tried Make, it output this (note the "unknown option character"):
 
[Bruce-Lewins-Computer:~/Desktop/jpeg-6b] lewinb% make
libtool --mode=compile gcc -O2  -I. -c ./jcapimin.c
libtool: unknown option character `-' in: --mode=compile
Usage: libtool -static [-] file [...] [-filelist listfile[,dirname]] [-arch_only arch] [-sacLT]
Usage: libtool -dynamic [-] file [...] [-filelist listfile[,dirname]] [-arch_only arch] [-o output] [-install_name name] [-compatibility_version #] [-current_version #] [-seg1addr 0x#] [-segs_read_only_addr 0x#] [-segs_read_write_addr 0x#] [-seg_addr_table <filename>] [-seg_addr_table_filename <file_system_path>] [-all_load] [-noall_load]
make: *** [jcapimin.lo] Error 1
[Bruce-Lewins-Computer:~/Desktop/jpeg-6b] lewinb% 
 
 
Why is this error coming up, and (more importantly), how can I fix it? I am on Mac OS X 10.2.8, and nearly any plain unix install will work, so I'm not sure what is so different with this.
 
 
Here is how my config flags were set on ImageMagick, if it helps:
./configure --enable-lzw --with-modules --without-bzlib --enable-shared --without-x
 
 
 
 
And here is the output from the attempted configure of jpeglib:
 
[Bruce-Lewins-Computer:~/Desktop/jpeg-6b] lewinb% ./configure --enable-shared host=UNIX
checking for gcc... gcc
checking whether the C compiler (gcc  ) works... yes
checking whether the C compiler (gcc  ) is a cross-compiler... no
checking whether we are using GNU C... yes
checking how to run the C preprocessor... gcc -E -traditional-cpp
checking for function prototypes... yes
checking for stddef.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for size_t... yes
checking for type unsigned char... yes
checking for type unsigned short... yes
checking for type void... yes
checking for working const... yes
checking for inline... __inline__
checking for broken incomplete types... ok
checking for short external names... ok
checking to see if char is signed... yes
checking to see if right shift is signed... yes
checking to see if fopen accepts b spec... yes
checking for a BSD compatible install... /usr/bin/install -c
checking for ranlib... ranlib
checking host system type... ltconfig: cannot guess host type; you must specify one
Try `ltconfig --help' for more information.
checking libjpeg version number... 62
creating ./config.status
creating Makefile
creating jconfig.h