My name is David, I'm working with limesurvey api to deploy surveys and gather responses for non-always-online enviroments.

I'm having issues with the export_reponses method through the json-rpc api.

I get the responses but only with a few fields (none directly related to the survey itself but the metadata limesurvey stores).

Example:
"id","submitdate","lastpage","startlanguage","token"
"1","1980-01-01 00:00:00","1","en",""


I tried this with both the online demo (Versión 2.05+) and with a local install (Versión 2.05+ Build 140320) having the same result.

This is the json data i'm sending:
{    "id" : 1,
     "method":"export_responses",
     "params": { "sSessionKey": "6czbhc5c72f69wjgtngpy2te8hqy46it",
          "iSurveyID":  621587,
                 "sDocumentType": "csv",
                 "sHeadingType": "full",
                 "sResponseType": "long" }
}

More details: changing the 'sDocumentType' value works, I can download the data as xls or html, yet the fields will always be the same few... Changing 'sHeadingType' or 'sResponseType' have no effect whatsoever!

I've tried to post this in the forum but I can't seem to find the captcha...

I'm actually using the API with Python.
Here's my code if anyone wishes to take a look.
https://github.com/dvinazza/lime-py-api


Did anyone suffer the same problems? Any ideas?

Thanks!

d