Issue with _getavailableport (OSX 10.6)

Help
2010-03-03
2013-04-25
  • TheOnlyHarry

    TheOnlyHarry - 2010-03-03

    When running one of the examples I run into the following error:

    $ python simple_server.py 
    /opt/local/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/site-packages/lightblue/_bluetoothsockets.py:42: DeprecationWarning: the sets module is deprecated
      import sets     # python 2.3
    Traceback (most recent call last):
      File "simple_server.py", line 8, in <module>
        sock.bind(("", 0))    # bind to 0 to bind to a dynamically assigned channel
      File "/opt/local/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/site-packages/lightblue/_bluetoothsockets.py", line 297, in bind
        address = (address[0], _getavailableport(self.__conn.proto))
      File "/opt/local/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/site-packages/lightblue/_bluetoothsockets.py", line 62, in _getavailableport
        result, channelID, servicerecordhandle = BBServiceAdvertiser.addRFCOMMServiceDictionary_withName_UUID_channelID_serviceRecordHandle_(BBServiceAdvertiser.serialPortProfileDictionary(), "DummyService", None)
    TypeError: Need 5 arguments, got 3
    

    It seems like the call to BBServiceAdvertiser.addRFCOMMServiceDictionary_<snip> does not return a tuple but the int value "-536870199" which causes the exception "'int' object is not iterable" to be thrown.

    Any ideas on how to fix this?

     
  • Anonymous - 2011-02-06

    Are there any news or updates related to this topic - i am having the same error!

     
  • Anonymous - 2011-06-06

    I also have the same error. Is this project dead?

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks