#1141 Liferea does not update feeds with TinyTinyRSS

v1.10
closed-fixed
None
7
2014-04-21
2014-02-25
No

This is a follow-up bug to #1123

I am using Liferea with TinyTinyRSS with feed updates via a cronjob.

Unfortunately bug #1123 is only partially fixed for me in 1.10.6 (the incorrect error message is gone): liferea still only updates the feeds after startup. Further updates can be seen only by restarting liferea.

Tested on Fedora 20 with self built 1.10.6 packages.

Discussion

  • Dominik Grafenhofer

    Reproduced on Fedora 20 with self built 1.10.7 packages.

     
  • Dominik Grafenhofer

    Reproduced on Fedora 20 with self built 1.10.8 packages.

     
  • Anonymous - 2014-04-10

    There are 2 common problems:
    1. the update job marker is not resetted after an update job has finished so a manual update will fail. (I have inserted "subscription->updateJob = NULL;" at the end of ttrss_source_subscription_list_cb() )
    2. The automatic update is working but the default update time for ttrss/opml is too long (60 * 60 * 24 sec => once a day) and there is another regression in the function subscription_auto_update(); the default time would be multiplied by 60 so the default update would happen every 60 days!

     
  • Fabian Henze

    Fabian Henze - 2014-04-10

    I see the same behaviour here. Updating the feeds only works once and is then ignored. The "automatic feed update" setting in the configuration is also ignored.
    The last debug log is:
    UPDATE : ttrss_source_update()

    I tried to debug the problem and found, that it stops because it mistakenly thinks some other update job is running. When I tried to get the state of the said job, liferea segfaulted. I guess something is calling update_job_free() on the updateJob, but is not NULLing it.
    I am a bit lost at this point, maybe a developer could have a look at it?

    I will attach a little debug patch, which shows what is happening and triggers the segfault.
    Just to make this clear: Do not apply this if you are a user just waiting for a fix, as it will cause liferea to crash.

     
    Last edit: Fabian Henze 2014-04-10
  • Fabian Henze

    Fabian Henze - 2014-04-10

    Also note that updating individual folders works (which might be another bug, as it should probably not work, if an updateJob is actually running).

     
  • Lars Windolf

    Lars Windolf - 2014-04-13

    Reproduced. Manual updates on child feeds work, but the TinyTinyRSS source is only updatable once after startup, thereby auto-update doesn't work.

     
  • Lars Windolf

    Lars Windolf - 2014-04-13
    • assigned_to: Lars Windolf
    • Priority: 5 --> 7
     
  • Lars Windolf

    Lars Windolf - 2014-04-13

    I believe to have fixed the following issues in git 1.10 branch:

    • updateInterval being to large (no being overwritten with -1 to enforce default update interval)
    • updateJob not being reset in callback (now enforced for all node source types)

    Thanks for the debugging guys. Please retest git branch 1.10 if possible!

     
  • Lars Windolf

    Lars Windolf - 2014-04-13

    Fix merged in git master now too.

     
  • Lars Windolf

    Lars Windolf - 2014-04-13
    • status: open --> open-fixed
     
  • Fabian Henze

    Fabian Henze - 2014-04-17

    Seems to work for me. Thanks a lot :)

     
  • Lars Windolf

    Lars Windolf - 2014-04-21
    • status: open-fixed --> closed-fixed
     
  • Lars Windolf

    Lars Windolf - 2014-04-21

    Fix released with 1.10.9. Please retest everyone!