#1140 Cannot navigate using keyboard inputs after waking from sleep mode

v1.10
closed
5
2014-11-23
2014-02-24
Levi Smith
No

Hello,
I am using Liferea v 1.10.5 on Ubuntu 12.04. The problem I am facing is that after waking from sleep mode, Liferea does not accept certain keyboard inputs. I can't move through the lists using the Up/Down arrow keys, or press Enter to open a feed in browser. It is also not possible to change the focus using the Tab key. Although, some keyboard shortcuts do seem to work since I can toggle read status using Ctrl+M or go to next unread item using Ctrl+N. But that is not always preferable.

Any help will be appreciated. Thank you.

Discussion

  • Levi Smith

    Levi Smith - 2014-02-24

    Update: It seems the problem occurs when Liferea goes in offline mode (which would happen when the laptop goes to sleep). The problem reoccurred after I accidentally clicked on Work Offline. After that, I once again could not use the keyboard, even after switching back to online mode. Hope that clears things rather than tangle them more.

    Update 2: Was unable to reproduce this. :(

     
    Last edit: Levi Smith 2014-02-24
  • Lars Windolf

    Lars Windolf - 2014-02-24

    My suspicion is that all menu hotkeys handled automatically by GTK+ keep working while the internal hotkeys implemented by Liferea stop working. This would explain the effect. Still I cannot imagine what triggers it.

    I cannot reproduce it.

    In the past when we used Mozilla as rendering engine it did tend to catch the keyboard focus and never release it...

     
  • Lars Windolf

    Lars Windolf - 2014-02-24
    • status: open --> closed-works-for-me
    • assigned_to: Lars Windolf
     
  • Lars Windolf

    Lars Windolf - 2014-02-24
    • status: closed-works-for-me --> open-works-for-me
     
  • Levi Smith

    Levi Smith - 2014-02-25

    Update 3: Tried v 1.10.6, did not put laptop in sleep mode, still the issue reoccurred after some time - after ~25 mins or so while Liferea was closed to tray. Don't know how to reproduce this.

     
  • Lars Windolf

    Lars Windolf - 2014-11-23

    Sorry, no further reports and no way to reproduce. I'll close it, but keep watch for other reports on the same.

     
  • Lars Windolf

    Lars Windolf - 2014-11-23
    • status: open-works-for-me --> closed
     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks