#1096 Update to 1.10.0 changes preferences values

v1.10
closed-fixed
None
5
2014-01-15
2013-07-18
stqn
No

Hi. I just updated Liferea from 1.8.15 to 1.10.0 on Arch Linux and several preferences have been automatically changed in the process:
- “Update all subscriptions at startup” has been checked (was unchecked before the update)
- “Default feed refresh interval” has been set to 1 instead of 0 (this may be caused by the change rendering impossible to set it to 0 anymore – I’ll open another ticket for that).
- “Show number of new items in the tray icon” has been unchecked.
There may be more.

Discussion

  • Lars Windolf

    Lars Windolf - 2014-01-15
    • status: open --> open-works-for-me
    • assigned_to: Lars Windolf
     
  • Lars Windolf

    Lars Windolf - 2014-01-15

    The source distribution contains a schema conversion definition "liferea.convert" that should (and does for me on Ubuntu) migrate the GConf keys to DConf. The definition file needs to be installed correctly for automatic conversion.

    Please test wether conversion did happens by running (from source root):

    gsettings-data-convert --verbose --dry-run liferea.convert

     
  • stqn

    stqn - 2014-01-15

    Here is what "gsettings-data-convert --verbose --dry-run liferea.convert" returns:

    Directory '/usr/local/share/GConf/gsettings' does not exist, nothing to do
    File 'file-roller.convert already converted, skipping
    File 'org.gnome.seahorse.manager.convert already converted, skipping
    File 'org.gnome.crypto.pgp_keyservers.convert already converted, skipping
    File 'shotwell.convert already converted, skipping
    File 'wm-schemas.convert already converted, skipping
    File 'gthumb.convert already converted, skipping
    File 'evince.convert already converted, skipping
    File 'org.gnome.crypto.pgp.convert already converted, skipping
    File 'gsettings-desktop-schemas.convert already converted, skipping
    File 'geoclue already converted, skipping
    File 'org.gnome.seahorse.convert already converted, skipping
    File 'gvfs-dns-sd.convert already converted, skipping
    File 'org.gnome.crypto.cache.convert already converted, skipping
    

    The command "sudo find / -xdev -name liferea.convert 2>/dev/null" does not return anything.

    Needless to say, I have restored the proper settings a long time ago and this is no longer a problem for me, so feel free to close this bug report :).

     
  • stqn

    stqn - 2014-01-15

    Oops, I see you wrote “from source root”… If you mean from a directory containing the source code of Liferea then I didn’t do this.

     
  • Lars Windolf

    Lars Windolf - 2014-01-15
    • status: open-works-for-me --> open-fixed
     
  • Lars Windolf

    Lars Windolf - 2014-01-15

    Found the problem. The following rules were missing in Makefile.am to install the convert file

    data_convertdir = $(datadir)/GConf/gsettings
    dist_data_convert_DATA = liferea.convert

    Fix will be included in 1.10.5. To be released soon.

     
  • Lars Windolf

    Lars Windolf - 2014-01-15

    For a manual hotfix manually copy "liferea.convert" to "/usr/share/GConf/gsettings/" and run

    gsettings-data-convert --verbose liferea.convert

    This will immediately migrate preferences.

     
  • stqn

    stqn - 2014-01-15

    I tried again from the top-level directory of Liferea’s source code, where the file liferea.convert is located, and I got the same output.

    Arch Linux’ PKGBUILD for Liferea 1.10.4 does not contain any reference to liferea.convert. It just runs ./configure, make and make install. And as far as I can see this is the case since 1.10.0 was out for Arch ( https://projects.archlinux.org/svntogit/packages.git/log/trunk?h=packages/liferea ).

     
  • Lars Windolf

    Lars Windolf - 2014-01-15

    I think this is related to this bug. As the file was not used during install, the maintainer dropped it. I guess this will fix with the next release.

    You can download the file from github https://raw.github.com/lwindolf/liferea/master/liferea.convert

     
  • Lars Windolf

    Lars Windolf - 2014-01-15
    • status: open-fixed --> closed-fixed
     
  • Lars Windolf

    Lars Windolf - 2014-01-15

    Fix released with 1.10.5