#15 Makefile rpm target fails on FC3

closed
None
5
2005-04-20
2005-02-23
No

Just wanted to let you know that on most modern
systems, you need to use rpmbuild now, not rpm. So if
you change the makefile rpm target to use 'rpmbuild
-ba' instead of 'rpm -ba' it will work better (at least
on anything released in the last few years I believe,
but most certainly on FC3).

thanks
charles

Discussion

  • Karl J. Runge

    Karl J. Runge - 2005-03-05
    • assigned_to: nobody --> runge
    • summary: Malefile rpm target fails on FC3 --> Makefile rpm target fails on FC3
     
  • Karl J. Runge

    Karl J. Runge - 2005-03-05

    Logged In: YES
    user_id=219571

    I am not an rpm expert (or even user these days...) but I
    have verified that
    rpmbuild exists on pretty old setups so I think the switch
    'rpm -ba'
    -> 'rpmbuild -ba' is OK. I only have root access on a
    redhat 9 machine
    where 'make rpm' seems to work all right.

    Could you please verify that both of these "mock" file
    releases generate
    the correct rpm's:

    http://www.karlrunge.com/x11vnc/LibVNCServer-0.8pre.tar.gz

    http://www.karlrunge.com/x11vnc/x11vnc-0.7.2pre.tar.gz

    Thanks,

    Karl

     
  • Charles Galpin

    Charles Galpin - 2005-03-05

    Logged In: YES
    user_id=14027

    Hi Karl

    I'm not home so don't have a FC3 box handy. I did however
    verify the rpms build fine on

    Red Hat 7.2
    Red Hat 9.0
    Fedora Core 2

    hth
    charles

     
  • Karl J. Runge

    Karl J. Runge - 2005-04-20
    • status: open --> closed
     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks