#345 SIGSEGV after inserting a block

master branch
closed-rejected
actions (81)
7
2013-02-08
2012-08-31
No

Hi,

I've inserted a bloc, and, just after, got a SIGSEGV

I was running librecad in gdb, please find attached the backtrace.

Regards

Jean-Luc

Discussion

  • Dongxu Li

    Dongxu Li - 2012-08-31
    • assigned_to: nobody --> dongxuli
    • priority: 5 --> 7
    • status: open --> open-accepted
     
  • Jean-Luc Coulon

    Jean-Luc Coulon - 2012-08-31

    New crash (SIGSEGV) in Modify -> Same property -> Indicate 1st entity -> select entities to change -> Crash

    I've the backtrace if needed (I don't know how to attach a file in a Comment of a bug)

    J-L

     
  • Jean-Luc Coulon

    Jean-Luc Coulon - 2012-08-31

    SIGSEGV gdb backtrace (same prop)

     
  • Dongxu Li

    Dongxu Li - 2012-09-03

    Could you please provide clear steps to reproduce? something like:

    1, start LibreCAD with an empty drawing;
    2, Draw a straight line by Main: Draw->Line->2 points;
    3, Main menu: Modify -> Property;
    4, select the line created in step 2;

    results: the program crashes with error message/bt

    expected result: the line is selected

     
  • Jean-Luc Coulon

    Jean-Luc Coulon - 2012-09-05

    Sorry but I've no simple action that reproduce the crash.
    After a crash, if I retry the same operation, I've not a crash again... but an other later.

    Generally speaking, the software is unstable, in intensive use I get quite many segfault.

    (i.e. one I see ofter is when using ctrl-z many times to delete several actions but, here again, I have not a simple case to reproduce the crash)

     
  • Dongxu Li

    Dongxu Li - 2012-09-06
    • status: open-accepted --> open-rejected
     
  • Dongxu Li

    Dongxu Li - 2012-09-06

    not enough info.

    Please open a new bug with a detailed description of steps to reproduce.

     
  • Claude Sylvain

    Claude Sylvain - 2012-09-12

    - Since that bug report was rejected, closing that bug report...

     
  • Claude Sylvain

    Claude Sylvain - 2012-09-12
    • status: open-rejected --> closed-rejected
     
  • Jean-Luc Coulon

    Jean-Luc Coulon - 2012-09-12

    Just a remark: it is not a good idea [tm] to hide a problem rejecting the bug.

    I've no real mean to provide enough informations but the problem is still living... and probably not only in this place. I will try to have a look with valgrin but I've not enought knowledge of the internals of librecad...

    Regards

    Jean-Luc

     
  • Jean-Luc Coulon

    Jean-Luc Coulon - 2012-09-12
    • status: closed-rejected --> open-rejected
     
  • Dongxu Li

    Dongxu Li - 2013-02-08

    Please do help the troubleshooting by finding a sequence to trigger the bug and report the bug with detailed steps to reproduce.

    Feel free to reopen this bug.

     
  • Dongxu Li

    Dongxu Li - 2013-02-08
    • status: open-rejected --> closed-rejected
     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks