On Thu, Jun 21, 2012 at 5:38 PM, Paul T. Bauman <ptbauman@gmail.com> wrote:
The FEInterface::is_vector_type() return type of bool is too
restrictive - we ought to be returning a type enum (TYPE_REAL or
TYPE_REAL_GRADIENT for now) to make it easier to extend later.

Will do. How does everyone feel about "FieldType" as the enum type for this?

I went with FEFieldType and renamed FEInterface::is_vector_type to FEInterface::field_type, which
returns an FEFieldType. Committed in r5719. Let me know if you don't like it and I'll change it.