Dear Libmesh users,

I succeeded in making petsc and libmesh work together. As feedback I would like to give some notes:

0) Versions:    redhat 9, shrike
                cvs-version of libmesh

1) I had problems with example 13, when I downloaded the latest official release from sourceforge. The laspack solver always converged in the first step, and gave non-realistic results. Downloading from the CVS solved the problem for the laspack solver. Mark that the output for ex13, using this solver, is not the same as given on the webpage of ex13, though the results are realistic.

2) Make sure that the shell variables PETSC_DIR and PETSC_ARCH are set before compiling libmesh with PetSc support.

3) I had PetSc compiled without mpi support. I tried to do the same for libmesh, however, if I tried to compile without mpi, the "./configure --without-mpi" automatically disabled PetSc-support. I could check this from: include/base/libmesh_config.h. So, as far as I can see, libmesh is not able to use PetSc without MPI.

4) PetSc has to be compiled with "make BOPT=O", the other options (g or O_c++) do not work with libmesh.

5) In "$PETSC_DIR/bmake/$PETSC_ARCH/packages" the MPI_LIB variable is set to "$MPI_DIR/lib/share", but the libraries are put in "$MPI_DIR/lib". Therefore, the snooped mpi library directory is not found by Libmesh. Changing to the correct path in $PETSC_DIR/bmake/$PETSC_ARCH/packages solved the problem.

I hope these notes will be useful to improve installation instructions for future users. I will move on to what I downloaded libmesh for: Solving differential equations.

Thank you for your support.

Kind regards,


dr. R. van Tol
Computer Simulations and Foundry Processes
tel.:09 2645704 - fax:09 2645848

WTCM-CRIF Belgian Center of the Technological Industry
Technologiepark 915, B-9052 Gent-Zwijnaarde
tel: 09 264 5697

WTCM-CRIF "Your Gateway To Innovation".
Have a look at the future of materials and manufacturing technology