Hi Guys, This isn't an issue directly with libdc1394, but I'm not sure. I basically have a 1394B adaptor card that will not "mount" the camera. I had two of my AVT cameras get fried from hot-plugging so now I have 1394b adaptor cards with locking screws however after turning the computer on with the camera plugged in i do NOT get a /dev/video1394 directory. If I instead use a different card(actually 4 different cards that we have), that doesn't have the locking screws, the video1394 directory appears and the camera works properly.

The card that doesn't work is this one by PointGrey:

Download Technical Datasheet

which is based on this Agere FW 643 chipset:


Has anyone had any experience getting these cards to work? I am trying to use Ubuntu 7.10 or 7.04, I haven't tried Fedora because the Firewire is so broken and annoying in Fedora right now. I have tried building the directory and node files by hand to to see if that helps, but that didn't work either, as libdc1394 complains when getting the camera list.

mknod /dev/raw1394 c 171 0
mkdir /dev/video1394
mknod /dev/video1394/0 c 171 16
modprobe raw1394
modprobe video1394

Any Ideas?