Installation on XP Help

  • Ken Gendrich

    Ken Gendrich - 2007-10-11


    I've read through the archives and could not find many good stories on windows xp installs.
    I have had a recent steep learning curve, and have muddled through it.
    I now find myself stuck in about 3 feet of mud and need an escape before I give up and go buy a mac :)

    So, here is what I've done so far.
    1.  Learned about gzip, untar
    2.  Installed and started apache 2.2.6
    3   Installed and started postgres sql 8.2.5
    4.  Installed and built dmake
    5.  Installed active perl
    6.  Uninstalled active perl :)
    7.  Installed perl 5.8.8 (vanilla-perl)
    8.  Downloaded what appears to be 1.2.99 from the site
    9.  Found the README file
    10.Learned about "perl"
    11.Discovered CPAN  (many times)
    12. Built every dependency EXCEPT for DBD::Pg
    13. Slept 6 hrs, started again...
    This is where I am stuck.
    I have tried CPAN DBD::Pg (Forgot what went wrong after 2 hrs of research)
    I have tried downloading the PG-1.49 source for windows (2x)
    [both appear to make and compile fine, but fail the signature test and the Use DBG::Pg tests]
    There is a strange error.  I say strange because the system fails to load pg.dll even though pg.dll is in the specified location
    Can't load 'C:\dbd\DBD-Pg-1.49\blib\arch/auto/DBD/Pg/Pg.dll' for module DBD::Pg: load_file:The specified module could not be found at C:/vanilla-perl/perl/lib/ line 230.

    See attachment DBFTestfail.png
    What's strange is that pg.dll IS in that location AND  notice the / after "arch" that should be a \

    I even modified the where this is specified, after which make failed miserably....

    So, I installed the component anyway, successfully, and then guess what perl turned up:
    install_driver(Pg) failed: Can't load 'C:/vanilla-perl/perl/site/lib/auto/DBD/Pg
    /Pg.dll' for module DBD::Pg: load_file:The specified module could not be found a
    t C:/vanilla-perl/perl/lib/ line 230.

    Same error message, but correct slashes and the file is really there as well...
    See Attachment AdminFail.png

    Final questions:  Is there a windows template of ledgersmb.conf, I had to guess on a lot of settings
    Most of all, what is the database name?  Is it host, localhost or the database instance in pg_adminIII?


    Thanks, I hope there is a guru out there to get me past this roadblock ....

    - Ken G

    • Chris Travers

      Chris Travers - 2007-10-11

      I replied to this on the -users list.  But for those who are not on that list and may come across this, the issue has to do usually with an inability to load PostgreSQL client libraries, usually becuase the system cannot fund them.

      The preferred option is to alter your PATH environment variable to include the path to those libraries and try again.


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks