No logs from LCDd and won't start

Help
AMyatt
2014-07-13
2014-07-21
  • AMyatt

    AMyatt - 2014-07-13

    Hi,

    I have installed LCDproc 0.5.7 on FreeBSD 8; LCDproc will run and log that it timed out connecting to LCDd, but LCDd won't run and nothing gets printed to the log.
    Even if I run LCDd with "-s 0" and/or "-f" it immediately returns to the prompt with not a single log line printed. I even tried with "-r 5".

    Any idea why I wouldn't be getting any logging? It is impossible to diagnose why it won't start when I'm getting no hints from it.

    Regards,

    Anthony

     
  • Markus Dolze

    Markus Dolze - 2014-07-21

    With regard to the mail you sent me on 2014/07/15 I guess you solved that. But here are some tips for others.

    On FreeBSD, if LCDproc is installed from the port or package no default config is installed. I should implement a more clever installation/deinstallation routine, but for now you need to copy the example /usr/local/etc/LCDd.conf.sample to /usr/local/etc/LCDd.conf.

    Otherwise LCDd does not find a valid configuration file and will immediately quit. If you run 'LCDd -f' you should see a note stating that, at least.

    You can instruct LCDd to use that sample config file anyway:

    /usr/local/sbin/LCDd -f -c /usr/local/etc/LCDd.conf.sample
    
     
    Last edit: Markus Dolze 2014-07-21

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks