#100 Digitally signed exe files do not run

3.x
closed-fixed
General (55)
7
2012-05-27
2012-01-04
Sean Kelly
No

I created two exe files with launch4j. (I cannot attach them to this ticket due to 256kb file size limitation at sourceforge)

The first exe file runs, the second one fails with error \'Could not find the main class: com.blah....\'.

The only difference between the first exe and the second exe is that the second exe is digitally signed using a code signing digital certificate.

Discussion

  • Sean Kelly

    Sean Kelly - 2012-01-04
    • priority: 5 --> 7
    • assigned_to: nobody --> grzegok
    • milestone: --> 3.x
     
  • Grzegorz Kowal

    Grzegorz Kowal - 2012-03-14

    Hi, the only way to get it working is to use the 'don't wrap the jar, launch only' option and sign the executable. Otherwise the jar will be corrupted and it will not work.

     
  • Grzegorz Kowal

    Grzegorz Kowal - 2012-03-14
    • status: open --> pending-works-for-me
     
  • Grzegorz Kowal

    Grzegorz Kowal - 2012-04-02
    • status: pending-works-for-me --> closed-works-for-me
     
  • Grzegorz Kowal

    Grzegorz Kowal - 2012-04-02

    This is not a bug there is a feature request for it.

     
  • Grzegorz Kowal

    Grzegorz Kowal - 2012-05-27

    Added sign4j utility (CVS).

     
  • Grzegorz Kowal

    Grzegorz Kowal - 2012-05-27
    • status: closed-works-for-me --> closed-fixed
     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks