Problems importing images

Help
Lena
2013-04-28
2013-07-08
  • Lena

    Lena - 2013-04-28

    Hi,
    I just installed the 0.9.2 Version but I had some troubles with importing images. It seems I can only import very small pictures (the icons for example). With all other pictures I get the following error:

    kxstitch: magick/cache-view.c:729: GetCacheViewVirtualPixels: Assertion `id < (int) cache_view->number_threads' failed.
    KCrash: Application 'kxstitch' crashing…

    I am using Fedora 18 with xfce but i installed the kde desktop and image magick.

     
  • Stephen Allewell

    Thanks for trying out the new version.

    Regarding your problem, I have just imported an image that was 1200x1500 pixels at 100% scale which worked fine.  Very slow to navigate, but it did import successfully.  I have also tried importing others with various other sizes with either limited colours or unrestricted colours and again these worked fine.

    From the error message, it would appear more of a problem with ImageMagick, I am using 6.6.5.8 here.  Which version do you have?  How big was the image that you tried?  Would it be possible to send it to me along with the parameters you were trying to import it with?  At least I would be able to test that particular image.

    Regards

    Steve

     
  • Lena

    Lena - 2013-07-06

    I have ImageMagick version 6.7.7-5 installed and the image was not very big.

    http://fedoraproject.org/static/images/panda-wave.png

    I also tried installing 6.6.5.10 version of ImageMagick from source. But then kxstitch failed to start completly and returning the following error message:

    kxstitch: error while loading shared libraries: libMagick++.so.5: cannot open shared object file: No such file or directory

     
  • Stephen Allewell

    I just imported the same image, 100% scale, limited to 50 DMC colours. Worked as expected.

    Did you compile KXStitch from source, or is it an installed package? If you compiled it yourself, did you recompile with the new version of ImageMagick++. Also have a check in /usr/lib/ for libMagick++, e.g. find /usr/lib/ -name 'libMagick' This will confirm if the library is there. You say you compiled it from source, did it by any chance get installed in /usr/local/lib* which may not be searched by default for shared libraries.

    Regards

     
  • Lena

    Lena - 2013-07-07

    I upgraded to Fedora 19 and installed ImageMagick 6.7.8-9 via yum. Now its working. Maybe there was a bug in ImageMagick 6.7.7. I don't know.

     
  • Stephen Allewell

    Good to know that it's sorted now. Thanks for reporting back.

    Regards

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks