Kxmame could not create a device option for..

Help
Joe
2006-09-03
2013-04-17
  • Joe

    Joe - 2006-09-03

    I keep getting the following message when selecting a game (tried both snes and genesis)

    "Kxmame could not create a device option for the selected rom"

    then

    "This error is usually due to either this system doesn't need a rom (bios only mode), or the file is not a valid rom for this system, or it is in a format that kxmame or xmess doesn't understand."

    I can get the games working from the command line, but have to specify the -cart option.

    Have I missed something in the configuration.

    (running version 2)

    PS took a while to work out that the snes bios needs to go in a sub directory called "snes" before it is detected. Don't know if this could be clearer?

    Joe

     
    • Toan

      Toan - 2006-09-04

      This is due to changes in mame/mess version >= 106 causing incompatibility. It's fixed in the CVS. I don't have a linux computer (nor time) at the moment to prepare a new beta release. Maybe, Chimpster (the current maintainer) could if you ask him politely :).

       
    • nonsense28

      nonsense28 - 2006-11-03

      I'm having the same issue.

      I'm using kxmame-2.0-beta compiled on Kubuntu 6.10 AMD64.  I received the same error listed above on xmess, but xmame works fine in kxmame. It looks like xmess/xmame .106 came out in May 2006 according to http://x.mame.net/.

      I just looked at the CVS files for kxmame here on sourceforge.net and most of them are dated to 14 months ago, so it does not look like the fix for xmess would be in the CVS for kxmame. 

       

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks