Problems compiling CVS (.Po files)

Help
Peter
2002-06-11
2002-06-12
  • Peter

    Peter - 2002-06-11

    Hi,

    I'm trying to compile the latest CVS I've just downloaded. I'm using a KDE 3 System under Debian, completly built from source.

    My problem seems to be very strange, since I haven't found ANYTHING about it with google :-(.
    Here a short description:

    I download the latest CVS,
    cd into the source,
    replace the admin dir with the one from kdebase (also tried with the one from crissi, showed no effect)
    and typed:
    make -f Makefile.cvs
    ./configure
    make

    after make appears almost directly an error.
    Something about files like
    .dep/kxmainwindow.Po that can't be found. There are about 4 or 5 such files with the suffix .Po (all of them have equivalents in the kxicq/ subdir with the endings .cpp and .h.
    But this Po files are nowhere, not even this .dep/ Subdir. I've tried everything, but nothing has helped so far :-(.

    I also downloaded the CVS.tgz file from crissi. There I have the same problem.
    BUT:
    When I use crissi's source-tree, and skip the
    make -f Makefile.cvs
    everthing works fine?!!?!?!? I don't understand what's going wrong!?!?
    I would like to use the newest CVS, because there are some nice features included :o).

    thanks for help,
    ciao Peter

     
    • Peter

      Peter - 2002-06-12

      I think I've found the problem.
      Perhaps the problem was a wrong automake version or so. The ./configure command build a config.status and used there

      if (sed 1q $mf | fgrep 'generated by automake') > /dev/null 2>&1; then

      "generated by automake" doesn't appear in the first line, but in the third.
      so a change in

      if (sed 3q $mf | fgrep 'generated by automake') > /dev/null 2>&1; then

      and afterwards a

      ./config.status && make

      solved the problem :o).

      ciao, Peter

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks