#4 support for API of FLAC v1.1.3 and v1.1.4

closed
compiling (9)
5
2012-09-30
2007-06-07
No

This patch is a backport of SVN rev 1984 to kwave-0.7.9 for supporting the changed API of libFLAC versions v1.1.3 and v1.1.4. FLAC versions v1.1.2 and v1.1.1 (and older) are still supported too.

related:
- SF bug #1713655
- debian bug #426668
- debian bug #427747

Discussion

  • patch for new data types / signatures of FLAC++ API

     
    Attachments
  • Logged In: YES
    user_id=37622
    Originator: YES

    File Added: debian-431199.diff

     
  • Logged In: YES
    user_id=37622
    Originator: YES

    The second patch is for fixing the data types of some FLAC++ methods that have changed since FLAC v1.1.1.

    It must be applied after kwave-0.7.9_flac-v1.1.3_and_v1.1.4-support.diff !

    related:
    - debian bug #431199

     
  • Logged In: YES
    user_id=37622
    Originator: YES

    now integrated in release v0.7.10