Help me with PIC

  • omkar sudame

    omkar sudame - 2010-11-06

    with reference to section 2.3 micro-controllers whenever I am dragging PIC into circuit page it is showing just a block saying no program loaded but no physical pin structure also not asking for choice of PIC.

  • allenm

    allenm - 2010-11-07

    You need a code file to load into the PIC processor. Without some code the PIC icon is "dead"; it has no connectors so you can't hook it up to any components.

    All you need to do is FILE>NEW, select ".flowcode" and "OK". Then pull anything from the "Flow Part" tool bar onto the workspace. I just pulled a "Start" icon over. Save it. Open your "circuit" file, select the PIC processor icon and then go find the .flowcode file you just created and OK that. You should be able to attach components to the PIC at that point.

  • omkar sudame

    omkar sudame - 2010-11-08

    I tried it but whenever I am specifying location of flow-code file instantly program is getting terminated itself, I tried even after pausing simulation.

  • allenm

    allenm - 2010-11-08

    I can't help you with the termination problem. I run into it myself all the time. The program just crashes sometime when I do something I've done before successfully. Ah the joys of open source code.

  • Zoltan P

    Zoltan P - 2010-11-08

    When ktechlab suddenly closes, than it has just crashed.
    We (developers) know about the problem and we are working on a better version. If you look into the source code, then you won't wonder why it crashes ;)
    Of course if the problem is reproducible, then feel free to file a bug report about it, and we try to fix it.


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks