Licensing issues solved in KScope 1.3.4

The new version of KScope generates call graphs using the 'dot' executable, instead of dynamically linking with graphviz. This shoukd finally solve all licensing problems in the 1.3.x branch, at the expense of a minor performance hit.

Note to upgraders: Use the Settings/Programmes page to set the full path of the dot executable (you can use the auomatic script to do that).

Note to packagers: The graphviz library is no longer required to compile KScope. On the other hand, Flex and Bison are now required, in addition to all previous dependencies.

Posted by Elad Lahav 2006-04-14

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks