Switch back from Fullscreen

Users
2004-08-04
2004-08-05
  • Bruce Bogaard

    Bruce Bogaard - 2004-08-04

    Is it possible to switch out of Fullscreen mode?

    When I start kplayer now, it always begins
    in Fullscreen mode and I cannot find a way
    to return to the smaller geometry when it
    started for the very first time.

    I tried  kplayer --geometry 400x350
    but that had no effect - right to Fullscreen.

    I'm using kplayer from the package
    kplayer-0.5.1-0.lvn.1.2.i386.rpm,
    running on Fedora Core 2 at 2.6.6-1.435.2.3.

    Thanks for such an outstanding addition to KDE.

     
    • kiriuja

      kiriuja - 2004-08-05

      Hi Bruce:

      Yes of course KPlayer should start in non-fullscreen mode initially. Does it go full screen even if you start it without a file, for example by going to the KDE menu, opening Multimedia submenu and clicking the KPlayer entry?

      If it is really in full screen mode, you should be able to right click to get a popup menu and unselect the full screen mode.

      Could you please run kplayer from the command line without arguments, and send me by e-mail (kplayer-bugs at en-directo dot net, or just post here) the entire output that you will get on the console?

      Thank you!

       
    • Bruce Bogaard

      Bruce Bogaard - 2004-08-05

      Starting from the KDE menu after a fresh login,
      kplayer started with small screen.  But, after
      playing movies awhile and quitting, then starting
      from the KDE menu, kplayer came up in
      full screen mode.  Right-clicking showed
      FullScreen greyed-out, not selectable.
      Using the Min/Max button in the window
      title, I was able to get to small screen mode,
      BUT right-clicking showed Full Screen greyed-out!

      Starting from the command line produced no output.
      I am willing to uninstall the RPM and try to compile
      the source, if that would produce some useful output.

      But before taking the compile source step, here's
      what happened, starting from the fresh login:

      Start kplayer from the KDE menu - small.
      Press the blue right-arrow button to play
      a movie and immediately went to full screen.

      With the movie playing, right-click and select
      Full Screen.  Window briefly changed to small
      and immediately returned to full screen.  Movie
      continued playing throughout.  Press stop and quit.

      Start from command line and immediately got
      full screen.  Right-clicking showed Full Screen
      greyed-out.  Press play, movie playing, right-click
      select Full Screen - window jumps a bit but stays
      at full screen.  There was nothing on the console.
      Press stop and quit.

      Changed to a never-before-played movie, and
      started from the command line.  Small screen,
      press play and got full screen immediately.
      All the behavior was the same as before,
      still no console output.

      Let me know what other steps I can take.

       
    • Bruce Bogaard

      Bruce Bogaard - 2004-08-05

      Looks like this is an Operator Error.

      After reading the README file for kplayer,
      I began reading the Online HOWTOs and found
      Advanced KPlayer configuration micro-HOWTO.

      Under General Settings, I unchecked
      "Resize...automatically" and now Ctrl+F
      nicely toggles between full screen
      and small window.

      Sorry for the unnecessary forum entry.

       
    • kiriuja

      kiriuja - 2004-08-05

      The entry is not at all unnecessary. This is a known problem, and at one point I will need to figure out a way to syncronize with KWin better. I will then need your help testing it, because I am not getting this problem myself. Is KWin your window manager? What version?

      Just to clear up the confusion, full screen mode is when the window has no title bar and no border. If you have them, then the window is either maximized, or if you cannot see the little minimize, restore and close boxes at the top right of the title bar then the window is just too big to fit your screen. Again, this is because of poor communication between KPlayer and KWin. When you unchecked the option, KPlayer stopped resizing the window automatically, but the size may be different than before you go full screen.

      The Full Screen menu item is greyed out when there is no current file or the current file is audio only, and the window is not full screen, no matter how big it is.

      If the window is full screen when you quit KPlayer, next time you play video the window will automatically go full screen again.

      Your packager probably configured KPlayer with --enable-debug=no, so you are right, you would have to compile from source to get console output.

       
    • Bruce Bogaard

      Bruce Bogaard - 2004-08-05

      Is KWin my window manager?  I am not able to
      answer that question.

      I tried using the  env  command to check - no luck.

      Looking in  /etc/sysconfig/desktop gives DESKTOP="KDE".

      So, I have run out of places to look for the answer.

      Please tell me how to find the answer to your question.

      Thank you for the clarification of fullscreen mode.
      That is what I see- no title bar, no border.

      Again, if you arrive at the point where
      --enable-debug=yes will give you information
      about the FullScreen switching, please do not hesitate
      to ask.  I am more than willing to uninstall the RPM
      and compile the source.

       
    • kiriuja

      kiriuja - 2004-08-05

      If ps shows KWin running then it probably is your window manager. So run

      ps -auxww | grep kwin

      Also a lot of times the /etc/alternatives/x-window-manager symlink will point to the current window manager, but not necessarily.

      ls -l /etc/alternatives/x-window-manager

      Then you can run

      kwin --version

      and it will tell you its version.

      Right now no need to compile from source. When I get to it I will let you know.

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks