Installing under Ubuntu

dregad
2014-06-02
2014-11-18
  • dregad
    dregad
    2014-06-02

    Greetings

    I've been using your plugin for sometime now on a Windows PC, and after having resolved the initial difficulties with the setup due to the spartan and somewhat outdated documentation, I have to say it's great - many thanks for your efforts.

    Today I tried to set up latest version 1.6.0 on an Ubuntu 14.04 laptop, running latest available KeePass package (2.25). I completed the setup just like on my Windows box, but when I start the program I get


    KeePass

    The following plugin is incompatible with the current KeePass version:
    /usr/lib/keepass2/plugins/GoogleSyncPlugin.plgx

    Have a look at the plugin's website for an appropriate version.


    Any ideas ?

     
    Last edit: dregad 2014-06-02
  • Hi,

    you need to install the package "mono-dmcs". Its the mono C# compiler. And also check that the plugin is readable and executable for users eg.

    "chmod go+rx /usr/lib/keepass2/GoogleSyncPlugin.plgx"
    
     
  • Yehonal
    Yehonal
    2014-11-15

    I've ubuntu 14.04 64bit with both mono-dmcs and run permissions on plgx file, but it gives the same error of @dregad

    keepass2 v2.28 ( also tried with 2.25 ) and kp-googlesync 2.0

     
    • Uranium235
      Uranium235
      2014-11-18

      Due to the Google API SDK for .Net not playing nice with mono, the plugin will not work with Linux.