Hi Sriram,
Sorry for spamming again. I was sleepy and forgot to give the backtrace
(gdb) bt 10
#0  0x0000003c4f030265 in raise () from /lib64/libc.so.6
#1  0x0000003c4f031d10 in abort () from /lib64/libc.so.6
#2  0x0000003c4f0296e6 in __assert_fail () from /lib64/libc.so.6
#3  0x00000000004cf66b in KFS::ChunkManager::~ChunkManager (this=0x7d90c0,
    __in_chrg=<value optimized out>) at /home/mine/kfs-0.5/src/cc/chunk/ChunkManager.cc:388
#4  0x00000000004cf6e6 in __tcf_7 () at /home/mine/kfs-0.5/src/cc/chunk/ChunkManager.cc:79
#5  0x0000003c4f0333a5 in exit () from /lib64/libc.so.6
#6  0x0000000000524578 in KFS::MetaServerSM::HandleReply (this=0x7d9c60, iobuf=0xa62fab0,
    msgLen=48) at /home/mine/kfs-0.5/src/cc/chunk/MetaServerSM.cc:375
#7  0x0000000000524e93 in KFS::MetaServerSM::HandleMsg (this=0x7d9c60, iobuf=0xa62fab0, msgLen=48)
    at /home/mine/kfs-0.5/src/cc/chunk/MetaServerSM.cc:351
#8  0x0000000000523140 in KFS::MetaServerSM::HandleRequest (this=0x7d9c60, code=1, data=0xa62fab0)
    at /home/mine/kfs-0.5/src/cc/chunk/MetaServerSM.cc:280
#9  0x0000000000526c02 in KFS::ObjectMethod<KFS::MetaServerSM>::execute (this=0x7d9c68, code=1,
    data=0xa62fab0) at /home/mine/kfs-0.5/src/cc/libkfsIO/KfsCallbackObj.h:88


--- On Thu, 5/5/11, Sriram Rao <sriramsrao@gmail.com> wrote:

From: Sriram Rao <sriramsrao@gmail.com>
Subject: Re: [Kosmosfs-users] KFS on Centos and Ubuntu
To: "Tung Nguyen" <betaisao@yahoo.com>
Cc: kosmosfs-users@lists.sourceforge.net
Date: Thursday, May 5, 2011, 5:27 PM

Hi Tung,
Can you load the core into gdb and get me a backtrace?

On Thu, May 5, 2011 at 9:35 AM, Tung Nguyen <betaisao@yahoo.com> wrote:
I would like to install KFS on a cluster that has chunkservers running in Centos and metaserver running in Ubuntu (our gateway). 

I ran the kfssetup script to distribute binary to the chunkservers but I failed to start the system. I checked the kfsping and there's no chunkserver connecting to the metaserver.

I digged into the chunkserver (CentOS) and modified the kfsrun script to print out the errors. I got:
#scripts/kfsrun.sh -s -c -f bin/ChunkServer.prp
Usage: grep [OPTION]... PATTERN [FILE]...
Try `grep --help' for more information.
Starting chunkserver...
bin/chunkserver: error while loading shared libraries: libcrypto.so.0.9.8: cannot open shared object file: No such file or directory

In Centos /lib or /lib64, I only found libcrypto.so.0.9.8e
so I created symbolic link from  libcrypto.so.0.9.8 to libcrypto.so.0.9.8e and ran it again. I got:
scripts/kfsrun.sh -s -c -f bin/ChunkServer.prp
Usage: grep [OPTION]... PATTERN [FILE]...
Try `grep --help' for more information.
Starting chunkserver...
bin/chunkserver: /lib64/libcrypto.so.0.9.8: no version information available (required by bin/chunkserver)
bin/chunkserver: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.10' not found (required by bin/chunkserver)

Issuing:  "#ldd -v /bin/sh I" had:
        libtermcap.so.2 => /lib64/libtermcap.so.2 (0x0000003c4fc00000)
        libdl.so.2 => /lib64/libdl.so.2 (0x0000003c4f800000)
        libc.so.6 => /lib64/libc.so.6 (0x0000003c4f000000)
        /lib64/ld-linux-x86-64.so.2 (0x0000003c4ec00000)

        Version information:
                libdl.so.2 (GLIBC_2.2.5) => /lib64/libdl.so.2
                libc.so.6 (GLIBC_2.4) => /lib64/libc.so.6
                libc.so.6 (GLIBC_2.3) => /lib64/libc.so.6
                libc.so.6 (GLIBC_2.3.4) => /lib64/libc.so.6
                libc.so.6 (GLIBC_2.2.5) => /lib64/libc.so.6
                libc.so.6 (GLIBC_2.4) => /lib64/libc.so.6
                libc.so.6 (GLIBC_2.3.4) => /lib64/libc.so.6
                libc.so.6 (GLIBC_2.2.5) => /lib64/libc.so.6
                ld-linux-x86-64.so.2 (GLIBC_PRIVATE) => /lib64/ld-linux-x86-64.so.2
                libc.so.6 (GLIBC_PRIVATE) => /lib64/libc.so.6
                libc.so.6 (GLIBC_2.2.5) => /lib64/libc.so.6
                ld-linux-x86-64.so.2 (GLIBC_2.3) => /lib64/ld-linux-x86-64.so.2
                ld-linux-x86-64.so.2 (GLIBC_PRIVATE) => /lib64/ld-linux-x86-64.so.2

Please let me know what can I do? I also tried to download, compile from source and ran the kfsrun script but I got a core dump
Total space = 31457280
cleanup on start = 0
Chunk server rack: 18
using cluster key = lagoon-cluster
chunkserver: /home/mine/kfs-0.5/src/cc/chunk/ChunkManager.cc:388: KFS::ChunkManager::~ChunkManager(): Assertion `mChunkTable.empty() && ! mChunkManagerTimeoutImpl' failed.
scripts/kfsrun.sh: line 25: 12193 Aborted                 (core dumped) build/bin/$server $config $SERVER_LOG_FILE

Thank you

WhatsUp Gold - Download Free Network Management Software
The most intuitive, comprehensive, and cost-effective network
management toolset available today.  Delivers lowest initial
acquisition cost and overall TCO of any competing solution.
Kosmosfs-users mailing list