Unable to configure library (LD_LIBRARY_PATH)

Help
Vnisor
2008-04-02
2013-04-25
  • Vnisor

    Vnisor - 2008-04-02

    Hi,
        I have configured the server on single machine. Actually, I'm not able to set LD_LIBRARY_PATH in environment. So, I have copied the .so files to /usr/lib folder manually. But, while running the KfsSample.java program, I'm getting runtime error as below.

    java.lang.UnsatisfiedLinkError: /usr/lib/libkfs_access.so: /usr/lib/libkfs_access.so: wrong ELF class: ELFCLASS64 (Possible cause: architecture word width mismatch)
        at java.lang.ClassLoader$NativeLibrary.load(Native Method)
        at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1751)
        at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1676)
        at java.lang.Runtime.loadLibrary0(Runtime.java:823)
        at java.lang.System.loadLibrary(System.java:1030)
        at org.kosmix.kosmosfs.access.KfsAccess.<clinit>(KfsAccess.java:89)
        at KfsSample.main(KfsSample.java:53)
    Unable to load kfs_access native library

    Kindly help me to resolve the above issue.

     
    • sriramsrao

      sriramsrao - 2008-04-02

      Hi,

      What platform are you on?  It looks like the .so is built for 64-bit architecture, but you are running the  JVM with a 32-bit setting.  Can you run the JVM with 64 bit (on Solaris, it is (java -d64).

      Also, please post this on kosmosfs-users mailing list so that others will benefit.

      Sriram

       

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks